Plone3-site no more works (Jaunty and Karmic alpha1)

Mirto Silvio Busico mirtosilvio.busico at fastwebnet.it
Tue May 19 15:42:38 UTC 2009


Derek Broughton ha scritto:
> Mirto Silvio Busico wrote:
>
>   
>> I'm no more able to use plone in Kubuntu.
>>
>> Looking at the plone log I see that it fails because the python-imaging
>> package is missing.
>>
>> The problem is that plone/zope2.10 are tied to python2.4, but
>> python-imaging (and also other packages I need like python-ldap) are
>> installed only in python2.5 and python2.6
>>
>> Any hint to resolve this problem?
>>     
>
> You bet.  You _are_ using buildout, I trust.  Fortunately, I'd already been 
> using this solution (for PIL at least - I don't know about python-ldap, but 
> for libxml2-python, I just added it to the eggs list and added it's tarball 
> URL to "find-links") for my Windows Plone installs.  Add to your 
> buildout.cfg:
>
> parts =
> ...
>     PIL
>
> [PIL]
> # Build egg with Chris McDonough's custom packaging of
> # setuptools-compatibile PIL
> # http://article.gmane.org/gmane.comp.web.zope.devel/13999
> recipe = zc.recipe.egg
> find-links = http://dist.repoze.org/
>
>   
Well, it was a long story.

I tried the unified installer of Plone. It is buildout based and works.
Then I tried to add the plone-ldap package and, after days of googling 
end trying different recipes, I ended with a buildout that generates an 
error when compiling openldap-2.3.39 when generating getpeereid.o

So I also tried the development version of Plone ( svn co 
https://svn.plone.org/svn/plone/PloneOrg/buildouts/trunk/devel/ ) and 
obtained the same error.

As a last resort I tried to use the plone distributed with ubuntu (some 
month ago it worked - but it was on Intrepid) and I found that Plone no 
more works.

Any solution that gives me a working Plone3 with LDAP support is good.

Thanks
    Mirto




-------------- next part --------------
A non-text attachment was scrubbed...
Name: mirtosilvio_busico.vcf
Type: text/x-vcard
Size: 272 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/kubuntu-users/attachments/20090519/aef21b51/attachment.vcf>


More information about the kubuntu-users mailing list