**RESOLVED**Re: permission

steven vollom stevenvollom at sbcglobal.net
Tue May 19 00:12:06 UTC 2009


On Monday 18 May 2009 06:49:49 pm clay weber wrote:
> steven vollom wrote:
> > On Monday 18 May 2009 02:57:59 pm Eberhard Roloff wrote:
> >> steven vollom wrote:
> >>> I just installed Digikam in Jaunty kde 4.2.3.  It said I did not have
> >>> permission.  I typed sudo digikam into a terminal and got the
> >>> following: steven at Yeshua:~$ sudo digikam
> >>> Error: "/var/tmp/kdecache-steven" is owned by uid 1000 instead of uid
> >>> 0. Error: "/tmp/kde-steven" is owned by uid 1000 instead of uid 0.
> >>> digikam(5182) Digikam::DigikamFirstRun::DigikamFirstRun:
> >>> "/home/steven/Pictures"
> >>> steven at Yeshua:~$
> >>>
> >>> What do I do and how do I do it to get appropriate permission and
> >>> permissions fixed?  Thanks.  A neighbor was burglarized this morning
> >>> and I took pictures for him.  Thanks!
> >>>
> >>> Steven
> >>
> >> Dear Steven,
> >>
> >> when you use konsole and type
> >> digicam
> >>
> >> i.e. without sudo, what is the exact error that you get?
> >
> > I can't remember what it was before, but I think the comment was
> > something like no such file or directory.
> >
> > Nice to hear your voice, my friend.  I finally got it to work, however I
> > had a permissions problem.  The first couple of times, I got it to show
> > read and write permission for the owner, with the box at the bottom
> > checked for all folders etc.  Still twice, it retained root root at the
> > bottom.  Then finally it accepted the instruction on the third attempt,
> > and it works now, just before I answered your email.
>
> There should be no reason to run a non-admin program or tool using sudo
> or kdesudo (for GUI apps), else you can have problems such as this.
> While it is not too hard to fix, it is annoying to figure it out if you
> have never come across the issue before
>
>
> clay
The only reason I used sudo is because I was refused the program due to lack 
of permission.

I just tried sudo, like I would if using sudo Dolphin to change permissions.  
It did not work the first two times.  It said Owner had read/write however it 
remained root root down below in the box.  The third time it worked and 
permission was changed, and I could use the application.  What would you have 
tried if you wanted to download pictures and were refused due to a permission 
deficiency?

I have never come across the problem before either, and I have a fresh install 
of Jaunty with my partitions finally properly mounted, my system backed up 
properly, and just basic daily applications installed.

My neighbor was just burglarized and did not have a camera to record the 
damage.  He asked if I would take pictures and make a cd for him.  I did, but 
did not yet have digikam installed.  This is the first time I have had trouble 
installing digikam.  Nonetheless, it is the first time I have had a 64 bit 
system.  I never really know if new problems are due to the 64 bit 
applications, but that is what is different for me.  Oh, I also have all 
partitions with ext4 file systems for the first time.  FYI, I transferred 130gb 
of data into my backup in 31 minutes.  It was incredible.

I believe I will have less problems now.  For the first time, I have all my 
partitions mounted in /home/steven.  It is great, I can open dolphin in split 
screen and move every piece of saved data from the one open application.  
Additionally, no data is ever really in any jeopardy due to crash of 
application, only drive failure, and I have my data saved on two new drives.

Steven




More information about the kubuntu-users mailing list