run time error

Derek Broughton derek at pointerstop.ca
Wed May 13 13:00:44 UTC 2009


Brian Norman Wootton wrote:

> Below is a tarball extraction, when I run the executable I get the error
> you see. I'm guessing that there is a Library Path, similar to MANPATH,
> PATH, etc - because the wanted file is there and maybe the executable
> needs a library path set to enable it to find it. I've tried 'echo
> $LIBRARYPATH
> but that returns null. My memory has got the moth and what I'm trying
> to do might not work in kubuntu or for the gib executable. anyway, but...
> hopefully some-one can put me on the right PATH.
...
> ./gib: error while loading shared libraries: libgtk-1.2.so.0: cannot

A bridge player I see.  Where'd you get the tarball?  I'd like to try it.

> open shared object file: No such file or directory
> brian%ls -ls /usr/lib/libgtk-1.2.so.0
> 0 lrwxrwxrwx 1 root root 19 2009-05-12 19:26 /usr/lib/libgtk-1.2.so.0 ->
> libgtk-1.2.so.0.9.1
> 1464 -rw-r--r-- 1 root root 1493656 2008-01-05 19:43
> /usr/lib/libgtk-1.2.so.0.9.1
> brian%

ldconfig & /etc/ld.so.conf.d/ are the tools you need.
-- 
derek






More information about the kubuntu-users mailing list