Resume device. What is it?

Nigel Henry cave.dnb2m97pp at
Mon Mar 30 18:20:04 UTC 2009

On Monday 30 March 2009 18:52, Antonio Augusto (Mancha) wrote:
> Hey Nigel,
> For what i get your problem MIGHT be, indeed, related to UUID. UUID is
> used as a "symbolic" name to a device, so you ca use it instead of
> /dev/sda3 (which might change when you repartition your disk).
> What might be happening is that the UUID of /dev/sda3 was changed
> (maybe by the new install of F10?) and hence none of your OSs can find
> it. You can check this by looking at /dev/disk/by-uuid and seeing if
> there is a syn-link there pointing to /dev/sda3, if there is check if
> its the same name as used in /etc/fstab.
> The reason you see 0Mb swap may be because the UUID can't be found,
> and hence no swap is activated.
> To your other question: yes you can simple comment that line in fstab
> and replace it with the one form arch.
> Also, then you see "resume device", usually it refers to the partition
> used to store the contents of the RAM when you put your computer to
> hibernate (suspend do disk). Linux uses the swap space to store the
> contents of the RAM, so it can resume when booted.
> When you see a message like "waiting for resume device" or "resume
> device not found", it simply means that Linux was not suspended to
> disk, and is doing a cold boot. Nothing wrong with that.
> If you have any more questions please post them.
> Cheers,
> KM

Hi Antonio.

Thanks for your reply. Having booted up a few other distros on this machine, 
so as to post output on my previous post to the list, I've just tried F10 
again, which now boots up ok (No real surprise, as I often have problems with 
this Asus M2N-X Plus mobo). That said, fstab output from F10 is below, and /, 
and /home have UUID's, but swap is accessing /dev/sda3, and Gkrellm is 
showing 2000M-2000M free, which is correct. F10 was the last distro installed 
on this machine.

# /etc/fstab
# Created by anaconda on Mon Feb 16 21:08:47 2009
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
UUID=bd4e6a39-e802-44d4-9fd0-fc22692770b0 /                       ext3    
defaults        1 1
UUID=5d6d96b6-c815-4816-8bce-81c286210754 /home                   ext3    
defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/sda3               swap                    swap    defaults        0 0

/dev/sdb1               /mnt/sdb1               vfat    auto,umask=0    0 0
/dev/sdb2               /mnt/sdb2               vfat    auto,umask=0    0 0

Now a reboot into Kubuntu Intrepid 8.10, and with an edit to fstab, changing 
the UUID for swap to /dev/sda3, this appears to be ok after a reboot. See 
below for fstab output.

# /dev/sda3
#UUID=a2bc95ec-5fe4-4651-9ca5-7027344141e3 none            swap    sw              
0       0

#Swap reference changed by me
/dev/sda3             none           swap           sw       0 0

The above appears to have resolved the problem. On bootup with Intrepid, the 
bootup still hangs at the "waiting for resume device" line for a couple of 
seconds, but I'll let that go. At least Gkrellm now shows that swap is on.

Tried sudo swapoff /dev/sda3, and Gkrellm showed swap as 0M, then did sudo 
swapon /dev/sda3, and Gkrellm showed swap as 2000M-2000M free.

Thanks again for your reply Antonio.


> On Mon, Mar 30, 2009 at 13:26, Nigel Henry <cave.dnb2m97pp at> 
> > I booted up F10 this morning, after fixing an selinux related problem
> > yesterday, but the bootup stalled. I noticed an entry on the bootup
> > messages, "unable to stat resume device". Not wishing to waste time on
> > F10, as I'd had enough of that yesterday, I rebooted to Kubuntu Intrepid
> > (on the same machine), and Intrepid hung for a few seconds with "waiting
> > for resume device", then the bootup continued with no problems.
> >
> > I googled "resume device", and there are a whole bunch of hits, with
> > folks having various problems with it. It appears to be referencing
> > "swap", but why resume device. I would have thought that, that
> > description applied more to laptops, and my machine is a PC.

> > Nigel.

More information about the kubuntu-users mailing list