Home directories on NFS

Alvin info at alvin.be
Mon Mar 23 14:46:28 UTC 2009

I'm having major difficulties with a new server setup. Maybe it's a bit much 
to want at once, but here is what I want:

- Ubuntu server with kvm/qemu [DONE]
- Ubuntu JeOS with Kubuntu on that server [INSTALLED]
- remote acces with XDMCP [DONE]
- Home directories on NFS share [?]

Well, installing everything was no problem, but I have several difficulties. I 
tried using a Solaris 10 server with ZFS filesystems as NFS server. 
Performance was horrible. Starting any program (like Dolphin) took several 
minutes. Moving a window was something that could be done with a lot of 

Thinking it was the Solaris implementation of NFS, I tried using the virtual 
host as an NFS server. That worked a whole lot better. Desktop performance is 
very good.

However, now I noticed that Akonadi does not work. It just will not start. The 
first time, akonadi took the whole virtual machine down during the time where 
you see the program bar. (That's right. I couldn't even get in with ssh 
anymore.) I already tried setting the apparmor profile to complain instead of 
enforce. This makes no difference.

What could I be doing wrong? I'm starting to fear Akonadi just doesn't like 
NFS, but that would be a disaster. Can anyone confirm this?

More information about the kubuntu-users mailing list