Why won't my script run?

Howard Coles Jr. dhcolesj at gmail.com
Sat Mar 14 17:44:49 UTC 2009

On Saturday 14 March 2009 12:07:21 pm Mark Greenwood wrote:
> Another question for the boffins..
> My Acer Aspire One needs a special script to control the fan. This script
> is called /usr/local/bin/acerfand and, when I run it from the command line
> it does indeed control the fan. acerfand is a bash script which daemonises
> itself using magic I do not understand.
> To get it to start at boot I'm instructed to place the command line into
> /etc/rc.local, so ignoring comments my /etc/rc.local now looks like
> #!/bin/sh -e
> /usr/local/bin/acerfand
> exit 0
> If I run 'sudo /etc/rc.local' from the command line my fan script starts
> running, the fan is being controlled and I can see acerfand as a running
> process.
> On boot however, the script starts and then immediately exits (I put debug
> in, I can see it in syslog starting up and then exiting). There is no
> running process called acerfand after boot. Again, I type 'sudo
> /etc/rc.local' at a command line and now there is a running acerfand
> process.
> Why the different behaviour at boot, and how can I make it work?
> It worked on Mandriva.... ;)
> Thanks,
> Mark

It would be easier to copy your fan control script into the /etc/init.d 
directory and then add it to the /etc/rc#.d/ as a softlink with either 
"S##acerfan" or "K##acerfan"  (s is for start and the number is the order in 
which you want it to start, K is for kill or stop, and again the number 
indicates when you want it to stop relative to the other K's in the 

create a "acerfan" file (using /bin/bash instead of sh as its default on most 
Debian based distros) in /etc/init.d with the contents of what you put in 
rc.local (leaving off the "exit 0" line).
then softlink the script in rc2.d (default runlevel in Debian based distros) 
as follows:
ln -s /etc/init.d/acerfan /etc/rc2.d/S99acerfan
ln -s /etc/init.d/acerfan /etc/rc6.d/K03acerfan
that last line is optional.
Then see what happens.

See Ya'
Howard Coles Jr.
John 3:16!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/kubuntu-users/attachments/20090314/a66c861e/attachment.html>

More information about the kubuntu-users mailing list