Palm device sync problems - Solved!

Nigel Ridley nigel at
Thu Mar 5 21:16:04 UTC 2009

Nigel Ridley wrote:
> I've got a Palm Z22 and under Hardy I can't get it to sync at all.
> I did manage to get it to sync on my boy's Intrepid box - once! That was using KPilot. But not 
> anymore.
> I have since used JPilot and Gnome-Pilot which gave an error message that the permissions on 
> /dev/pilot wrong and that it couldn't write to /dev/pilot
> However /dev/pilot doesn't exist!
> Hitting the 'sync' button and doing a 'lsusb' (on my Hardy laptop) gives:
> Bus 003 Device 058: ID 0830:0061 Palm, Inc.
> Any advice or solutions?
> I did find this on one forum:
> <quote>
> Fixed. Simply a matter of editing the files under /etc/udev/permissions.d. KPilot 4.4.6 worked fine.
> <end quote>
> But he didn't say what he edited....
> Another suggested to:
> ln -s /dev/ttyS0 /dev/pilot
> chmod 0666 /dev/pilot
> But how do I know what tty to use?
> Blessings,
> Nigel

Thanks to all who replied.
The answer was to add myself to the uucp group - logout and then back in again.

The KpilotDaemon crashes constantly:

nigel at laptop:~$ kpilotDaemon
nigel at laptop:~$ ASSERT: "!name.isEmpty()" in /build/buildd/kdelibs-3.5.10/./kdecore/kinstance.cpp 
ASSERT: "!name.isEmpty()" in /build/buildd/kdelibs-3.5.10/./kdecore/kinstance.cpp (76)
KCrash: Application 'kpilotDaemon' crashing...

So I used jpilot and now am a happy camper :-)



More information about the kubuntu-users mailing list