Installed gnome-office to test, python + possibly other things messed up

Muzer muzerakascooby at
Thu Jun 4 18:07:12 UTC 2009

Muzer wrote:
> See the title.
> Somehow, whenever a lot of python scripts try to execute, I get this 
> error:
> /usr/bin/python: error while loading shared libraries: OO: cannot open 
> shared object file: No such file or directory
> The package managers are awfully confused because I tried to uninstall 
> gnome-office again and half of the packages are python-related, so 
> they refuse to be removed because of that error. Probably the most 
> annoying side-effect (or is this the main effect?) is that flash no 
> longer works, and neither does youtube-dl.
> If anyone can help me get python fixed again, that would be appreciated!
> Thanks,
> Muzer.

I managed to get python working (thanks for all the help guys ;p). The 
flashplugin-installer problem was different though, and I still haven't 
got that sorted. See below for more info.

Here is what happened:

At the beginning, python was broken. I had just installed gnome-office.

I attempted to uninstall flashplugin-installer. This worked. I then 
tried to re-install it and got the previous message. I removed it again 
so aptitude would stop bitching. Then I tried to remove gnome-office. It 
wouldn't go. I had to reinstall gnome-office otherwise both aptitude and 
apt-get did nothing. Then, I did a reinstall of python2.5 and python2.6 
and it worked again.

I've done some more research on the flash plugin problem, and though 
there were no exact cases like mine, there were many, many similar ones. 
However, I tried all the solutions I could find, to no avail.

I've found out, however, how you can get a more verbose error message. 
I've googled for the more verbose versions but there are 0 results. This 
is the output from the command:
muzer at muzer-desktop:~$ sudo nspluginwrapper -v -v -i 

*** NSPlugin Viewer  *** ERROR: /usr/lib/ version 
`GCC_4.2.0' not found (required by /usr/lib32/

nspluginwrapper: no appropriate viewer found for 

muzer at muzer-desktop:~$

(I've double spaced the lines so they are more clear; I've set up 
Thunderbird to do 80-width columns and can't figure out how to turn it 
off for individual lines).

So, any more help?

Version: 3.1
GCS/CM/IT d>++ s+:- a---- C+++ UL+++>++++ P+>+++ L+++>+++++ E---->--- W+++ N o? K? w--- O+ M-- V- PS PE? Y-- PGP- t+ 5? X- R-- tv+ b++ DI D G++ e- h! !r y 

More information about the kubuntu-users mailing list