Don't have permissions

David McGlone david at
Mon Jun 1 13:24:31 UTC 2009

On Monday 01 June 2009 04:03:11 am Jonas Norlander wrote:
> On Mon, Jun 1, 2009 at 5:03 AM, David McGlone <david at> wrote:
> > Hi all,
> >
> > last week I wiped my computer so I could re-partition to create another
> > partition and I went ahead and did a fresh install of Kubuntu and now I
> > cannot run my web server on that partition anymore.
> >
> > I set apache to /media/d/www and now when I try to view web pages I've
> > created, I get this error:
> >
> > Forbidden
> >
> > You don't have permission to access / on this server.
> > Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.1 with Suhosin-Patch Server at
> > buddy Port 80
> >
> > But If I change apache's virtual server path to /home/david/www and move
> > the www folder there, everything works. I'm wondering if it's a
> > permissions problem, but I doubt it because I can write to the partition
> > as normal user.
> As the error message say there are some permission problems. What
> permission do you have on /media/d/www and how is the partition
> mounted?

david at buddy:~$ ls -la /media/
total 77
drwxr-xr-x  5 root root     4096 2009-05-31 21:14 .
drwxr-xr-x 21 root root     4096 2009-05-31 21:14 ..
lrwxrwxrwx  1 root root        6 2009-05-26 20:23 cdrom -> cdrom0
drwxr-xr-x  2 root root     4096 2009-05-26 20:23 cdrom0
drwxrwx---  9 root plugdev 65536 1969-12-31 19:00 d

I tried changing the owner and permissions, but It will only work if the 
partition is unmounted, but when the partition is mounted, it changes back to 
root plugdev. and I can't change permissions when the disk is mounted. I even 
tried using dolphin and konq running as root, but when I do that, even as root 
I get this error:

Could not modify the ownership of file /media/d. You have insufficient access to 
the file to perform the change.

fstab entry:

UUID=8812-A612  /media/d              vfat    utf8,umask=007,gid=46 0       1

I was going to change the fstab entry, but I don't know enough to do so. I was 
going to change it so users could mount and un mount the partition.

by the way, where did the program in system settings go that allowed us to 
edit the ownership, and enabled users to mount/unmount etc, etc of partitions 

David M.

More information about the kubuntu-users mailing list