Problem playing a DVD

Michael Satterwhite michael at weblore.com
Mon Jan 5 16:55:00 UTC 2009


On Monday 05 January 2009 08:31:42 am Jonas Norlander wrote:
> 2009/1/5 Michael Satterwhite <michael at weblore.com>:
> > On Monday 05 January 2009 06:24:24 am Jonas Norlander wrote:
> >> 2009/1/5 Michael Satterwhite <michael at weblore.com>:
> >> > I have a DVD that I'd like to be able to play on my system. When I
> >> > look at the directory structure on it, I find that the VIDEO_TS
> >> > directory doesn't have execute permission ... IOW I can't list the
> >> > contents. I have libdvd installed, but I'm not sure how to get past
> >> > this problem.
> >> >
> >> > Can anyone offer any help?
> >>
> >> You don't need to mount a DVD-Video to play it (same for Audio CD).
> >> Just pop it in the reader and choose play DVD in Kaffeine. If the DVD
> >> is encrypted you need the libdvdcss2 library from the
> >> http://www.medibuntu.org/ repository read up on there site how to add
> >> it.
> >
> > That would be great ... if Kaffeine actually worked (at least in my
> > installation - I'm sure it's working properly in yours). My DVD drive
> > is /dev/scd0. For whatever reason Kaffeine insists on trying to open sdb5
> > - which has nothing on it. I do have libdvdcss2 installed. If I could
> > open the directory, I could manually select the video file to play. As it
> > is, it's Kaffeine is unusable with this DVD.
>
> Kaffeine is using Xine as its backend. You can change the Xines
> settings that Kaffeine using. Go to Kaffeine>Settings>Xine
> settings>Media and there change the dvd.device option to what ever
> device you are using. I have mine set to /dev/dvd that is a symlink to
> my dvd device /dev/scd0. It could be that you are suffering from the
> "Upgrade to Hardy removed my dvd symlinks bug" that i reported when
> upgraded to Hardy. Look at
> https://bugs.launchpad.net/ubuntu/+source/udev/+bug/223534 for a
> description and solution.

Apparently I'd been bitten by the bug and didn't know it. Problem solved. 
Thanks.





More information about the kubuntu-users mailing list