No Krunner for USB keyboard

Reinhold Rumberger rrumberger at web.de
Thu Dec 24 01:01:53 GMT 2009


On Thursday 24 December 2009, Dotan Cohen wrote:
> 2009/12/24 Reinhold Rumberger <rrumberger at web.de>:
> > On Wednesday 23 December 2009, Dotan Cohen wrote:
> >> > Make sure your client is set to forward key combinations like
> >> > this to the server.
> >>
> >> The client no longer exists!
> >>
> >> > BTW, I think you will find that Ctrl+Alt+Delete doesn't
> >> > work either.
> >>
> >> It still pops up the logoff options.
> >
> > OK, just to make sure: you're on the Dell, not using VNC to
> > remote control it? What happens if you kill the VNC server? Does
> > that fix the problem?
> 
> Correct. The USB keyboard is plugged directly into the laptop. The
>  VNC server was not started since I powered up. How can I check to
>  see if it is running anyway?

On a terminal, do the following:
ps aux | grep -i <exe_name>
Substitute the name of the VNC server executable. If this shows 
anything apart from the grep command, the server is running. ("aux" 
is just my favourite set of ps options that will display the name - 
any set that displays the name is fine.) Alternatively, you can 
locate the start script in /etc/init.d and see if it supports the 
status parameter.

> > Change to a
> > virtual terminal (e.g. Ctrl-Alt-F2) and use the USB keyboard to
> > get back (Alt-F7)?
> 
> The USB keyboard won't get me to a virtual terminal or back to 7.
>  I must use the builtin for that.

The idea is to use the internal to switch to a vterm and the USB to 
switch back to X to see whether the problem is restricted to X. Just 
typing in the vterm isn't going to work as that works even under X, 
as far as I understood you.

> > Does an on-screen keyboard work?
> 
> Yes, both for switching to a virtual terminal and for pulling up
>  Krunner.
> 
> I must stress that until today, I have been using _only_ the USB
> keyboard for months. All this worked until recently.

Were there any kernel/X server updates that came in after you 
rebooted the last time the problem didn't occur? Are there any very 
recent backups of /etc/X11/xorg.conf in /etc/X11? Does 
/etc/X11/xorg.conf suddenly contain some weird entry that only 
affects the USB keyboard?

Oh, and: have you tried searching launchpad for bugreports related to 
the VNC server?


  --Reinhold



More information about the kubuntu-users mailing list