Ubuntu 9.10 with Grub 2 installed in partition unable to boot

peter.soares at rogers.com peter.soares at rogers.com
Sun Dec 20 07:42:18 UTC 2009

I started by installing Ubuntu on my second disk.  When I had trouble booting I eventually tried using Ubuntu from a single partition on the first disk.   On attempts to rerun grub-install 

grub-install /dev/sda7

I get a the warning shown below but received no errors:

grub-setup: warn: Attempting to install GRUB to a partition instead of the MBR.  This is a BAD idea.
grub-setup: warn: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and its use is discouraged.
Installation finished. No error reported.

I am booting through Vista's bootmgr by copying the bootsector into the Vista partition using

dd if=/dev/sda7 of=/media/OS/NST/ubuntu91.mbr bs=512 count=1

Something that I have been doing with Ubuntu 9.04 and some earlier releases.  On attempts to boot 9.10 I get a blank screen with a blinking cursor.  Using a grub2 rescue CD I can boot Ubuntu by entering:

configfile (hd0,7)/boot/grub/grub.cfg

and Xbuntu starts.  I do not want to install into MBR because this box boots Windows7, Vista and XP (and losing access to Windows would be very painful).  Experiments with EasyBCD beta 2 have not worked for me.  I am trying to get the Vista bootmgr to boot Ubuntu without using the rescue CD.  Any ideas?

I assume the warnings from grub-install maybe causing trouble.  Since this method (the Vista BCD) worked OK with 9.04 I suspect grub2 and installing into a partition rather than the MBR.  Below are the contents of fdisk on the first disk:

fdisk -l /dev/sda

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x20000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           2       42475   341172405    7  HPFS/NTFS
/dev/sda3           42859      121115   628591351+   5  Extended
/dev/sda5           42859       58156   122881153+   7  HPFS/NTFS
/dev/sda6           58157      114739   454502916    7  HPFS/NTFS
/dev/sda7   *      114740      121114    51207155+  83  Linux

The second and third SATA units have no operating systems on them just data (after moving Ubuntu to the first disk).  sda1 - Vista, sda5 - XP, sda6 - Windows7.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/kubuntu-users/attachments/20091219/16027433/attachment.html>

More information about the kubuntu-users mailing list