Adventures in Kubuntu: A testimonial

David Ex crossbones.ex at gmail.com
Mon Dec 7 21:19:30 UTC 2009


This is just a story about my weekend with Kubuntu.  If Linux is your
primary OS then you certainly have a story of the same ilk.

I want to fool around with making Android apps.  I got some programming exp
points but never much used and IDE.  I would always use Kate on one desktop
and Konsole on another.  But I was told it'd be best to get the Android SDK
and use it with Eclipse.  So I did.
Google made it very easy with thier SDK/ update manager thingie.  And it
even plugged easily into Eclipse- I found that part amazing.  I ran into
some issues with Eclipse it's self.  Now I realize it was because I DLed
some tar file that basically had some generic binaries ready to go and so of
course there were some configuration problems.  Also on top of the at I had
issues even starting an Android project.
After about 8 hours of trying to get everything to work right (not strait
hours, in between whatever it is I do at work) I finally reinstalled Eclipse
from the Ubuntu repository and then realized that I could not see all the
feilds on the Android Project Wizard, I was using my Eee900 and the
screensize kinda cut it off.
As I mentioned I was at work so I was trying to multitask personal stuff on
my Eee as much as possible; updating some bugs, configuring Eclipse and
apt-get'ing some stuff.  And then I finally got my "Hello World" Android App
to run on the Android emulator, so I was very happy.

But then I had an improper shutdown.  After that Things acted very buggy.
First thing after start-up I am told that my HDA internal sound device is
disconnected or something meaning i could not listen to mp3s.  Also I could
pick up routers on my WiFi but I couldn't connect to anything... like the
click action wasn't registering.

I restarted in recover mode.  I checked for broken packages, had some broken
Linux Header packages, couldn't fix them because I couldn't connect via wifi
before logging in to KDE.  I Proceeded to do normal log in but I had to
manually to it from command line 9the command 'startx' is how you enter your
GUI mode for those who don't know).  Sound works and I can use WiFi again.
But I couldn't use the Package Updater because I "didn't have the
privilege"  Apparently somethings are different then when you let KDE start
up the normal way.
The second time I booted up using the same method I got the HDA sound error.
After that, I switched to root before preforming 'startx'.  Everything
worked fine so that I could watch Hulu in peace.  I created a new user while
in root.  My idea was to have an experiment- see how much of my original
user account I could use with the new user?  Would i be able to execute
binary files in my old User's Home folder?
I became distracted and accidentally logged into my old normal user account
(GRUB starts the defualt boot after time-out).
Now the original user account i was having issues with works fine.... Go
figure.

-- 
I am David and I approve this message
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/kubuntu-users/attachments/20091207/d558dbc7/attachment.html>


More information about the kubuntu-users mailing list