Unable to print in Karmic

Reinhold Rumberger rrumberger at web.de
Tue Dec 1 02:53:48 GMT 2009


<top-posting since I'm not answering any specific parts of the OP>

Have you already seen: 
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/427653

Not a solution, but you may want to watch that report, as one may 
crop up at any time.

  --Reinhold

Am Montag 30 November 2009 schrieb Mark Greenwood:
> I've discovered that since the update to Karmic my printer has
>  stopped working.
> 
> It's an Epson Sytlus Photo R1800. CUPS detects it, uses the
>  correct Gutenprint driver, and I can configure it using the KDE
>  Printers control panel exactly as I would expect.
> 
> However any attempt to print to it produces nothing. After a very
>  long delay I get an error in /var/log/cups/error_log something
>  like
> 
> Unable to write 8192 bytes to printer.
> 
> I've tried changing permissions in /var/spool/cups to 777, but
>  even before I did that I could see files appearing in there so I
>  don't think it's a permissions problem.
> 
> The printer's LED flashes during the period when nothing is
>  happening, so that would indicate the computer is sending data to
>  the printer, but the test page I'm trying to print is 151K, so it
>  must be doing it extremely slowly.
> 
> Also it worked perfectly under the previous distro I was using on
>  that PC (Mandriva 2009.1) so I think something in CUPS is very
>  broken. Googling it I see quite a few people with the same issue
>  on Karmic, but no solutions. Anybdy have any ideas?



More information about the kubuntu-users mailing list