Jaunty, Java and map24

Perry pwhite at bluewin.ch
Sat Aug 15 19:51:41 BST 2009


Le Saturday 08 August 2009 10:17:28 Perry, vous avez écrit :
> Le Saturday 08 August 2009 02:38:45 Bruce Marshall, vous avez écrit :
> > I just installed FF 3.5.2  from the normal repositories...   Didn't do
> > anything else.  And map24 still works fine.
>
> Since in previous mails you quoted just that point,
>
> > > Firefox3.5 could never see java and map24 displays,  *but not on
> > > separate window.*
>
> I take it for granted you have on top of the map in main window the "double
> square icon" next to the "monkey wrench icon". I will try to experiment
> somewhat more.

Hi,   

All of this works in Hardy, I could newer get map24 to work at all in Jaunty.

After a lot (I mean it, a week since last related mail) of experimentation 
here is what I got on Jaunty:
without sun-java6-bin+jre+plugin map24 does not work. If I install that
firefox 3.0 and 3.5 can recognise Java version 14 or 15 (from another binary 
install) and display map24 in separate window provided *icedtea plugin is 
removed*, and konqueror sometimes??? finds java.
Else, with iceadtea plugin, FF3 shows v16.0_0 and FF3.5 has no java, as for 
konk "http://www.java.com/en/download/help/testvm.xml"  returns the expected 
version but "http://www.java.com/en/download/installed.jsp" never returns.

It has all been (and still is) very confusing for many reasons:
1) In contradiction to the output of "java -version" v15 keept reapearing, it 
took me long to find out the "Java Control Center" keept a reference to this 
v15, and that it finally was of no great importance.
2) The role of this "icedtea plugin" wasn't apparent to me at first.
3) I started trusting results that seemed objective, like output 
of "http://www.java.com/en/download/help/testvm.xml" 
or "http://www.java.com/en/download/installed.jsp", but on occasions they 
behaved differently.
4) I also thought the output of "about:plugins" was objective, but whereas 
that of the FFs was consistent, that of Konq sometimes 'stuttered', it 
repeated twice the line with the version, followed by many lines seemingly 
identical (I guess it didn't bother to write versions numbers)
5) Some changes took an indefinite amount of time to be reflected, or a reboot 
was needed.
6) I had to find the command "sudo update-alternatives --config java" because 
I have two versions there (Jaunty) Why only one on hardy, with 
sun-java6...installed and Java Plug-in KJAS for Konqueror using a 
kjavaappletviewer.so?
Couldn't find much readily usable infoon KJAS...(but see 7_third below)
7) about:plugins on Hardy gives for Konq:
Java Plug-in  Java Plug-in KJAS for Konqueror  "kjavaappletviewer.so
  application/x-java-applet - Java Applet (class)
application/x-java-bean - JavaBeans (jar)"
and for FF3.0:
 a long list under "Java(TM) Plug-in 1.6.0_14-b08
Nom de fichier : libjavaplugin_oji.so		Java(TM) Plug-in 1.6.0_14"
 of java and bean stuff.
7_second)  about:plugins on Jaunty gives for Konq *both of the above*.
the FFs give only the long list as in Hardy.
7_third) that was after I removed (synaptic) the openjdk stuff.
7_fourth) I tried to make the configuration in Jaunty as similar as possible 
to the configuration in Hardy but konk resists and keeps relying on "the long 
list" despite attempts to empty cache and reboots 
8) Konq seems to have an erratic behaviour, eg after I selected 
in "update-alternatives --config java" the sun version in Jaunty:
Konk map24 opened with europa map as usual but then *showed the tool* for 
separate window but was not completely functional (no effect on confirming an 
address), I closed and reopened, then nothing worked. [hard to refrain 
putting "????" and  "!!!!" all over the mail]
9) I have already done a couple of reinstalls on the previous weeks and always 
had the same problem (as far as I cant tell because I understand it better, 
or rather I just know better what things to watch)
10) I tried all that I could (when applicable) in "Java konqueror Howto" and 
the like.

Reading the answer of Bruce Marshall on 2009-08-07 19:07 
> Map24 works fine here on  FF 3.5  and Jaunty.
I notice that he does not mention Konqueror, and I indeed belive my problem is 
with Konqueror, it "wants" to function, using KJAS, on a mode different from 
Firefox, but can't do it in Jaunty.
Isn't it a pitty that Konqueror, still the default viewer for internet, can no 
more be coerced into functionning correctly? Or is it my fault, some obvious 
thing I keept being blind about (as any translator *needs* a proof reader)?

Sorry for the long mail, I wanted to be as precise as possible to avoid 
replies for things I belive I already tried correctly. 

Perhaps *couple of simpe questions* will bring all of you to the point: 
1) has anyone been able, with Konqueror under Jaunty to use map24 (for me: 
http://www.ch.map24.com/ but you could try your local version), 
click on the "double rectangle" icon next to the "tool (monkey wrench) icon" 
to view it in a separate window, and click successfully ( means the map will 
zoom on the spot) on the left pane to confirm an address?
") what happens when you try 
 "http://www.java.com/en/download/help/testvm.xml" 
or "http://www.java.com/en/download/installed.jsp" ik konq?



If you have any comment, please answer (but note there is not important, it is 
only curiosity from my part, I'll stick to Hardy until I can master a 
*working* newer version that seems a good trade-off.)



Greetings		Perry



-- 
BOFH excuse #322: Your Pentium has a heating problem - try cooling it with ice 
cold water (Do not turn off your computer, you do not want to cool down the 
Pentium Chip while he isn't working, do you?)



More information about the kubuntu-users mailing list