Kubuntu 9.04 - system tray and panel lost! Nearly totally stuck! - SOLVED!

Bas Roufs basroufs at gmail.com
Tue Apr 28 09:48:27 UTC 2009

Hello Dotan, VT and everybody else

Thanks for the input of both of you!
In the mean time, I managed to solve the problem.

2009/4/28 Dotan Cohen <dotancohen at gmail.com>:
>>> Again, I have problems with the system tray and panel. They simply do
>>> not appear any more. A few times I tried to get them back as follows:
>>> via terminal > sudo mc > I copied .kde to .kde-orig and than I deleted
>>> recursively the .kde directory. After restarting the computer, I hoped
>>> to get back the panel and system tray, because I had done so when I
>>> experienced a similar problem with Kubuntu 8.10. But now, no system
>>> tray and panel do come back after restarting the system.

After writing my first message in this thread, I repeated the
procedure ascribed above. That 2nd attempt appeared to be successful.
Ever since, a new, more 'native' and fresh looking panel and system
tray keeps coming back whenever restarting the system. Also a typical
Kubuntu Jaunty feature has appeared now in the panel: the 'Network
Management'  package which seemingly replaces and old, slightly buggy
"Network manager" which I found in 2 previous versions of Kubuntu.

> If you are removing ~/.kde then KDE _might_ be rewriting it before you
> have the chance to log out.

It is quite possible that this happened after my failed first attempt,
because I waited to long to log out after deleting ~/.kde.

> Instead, log out (go to the KDM screen),
> press Ctrl-Alt-F4, then log into the terminal and run "mv .kde
> .kde-original". Log out of the terminal, press Ctrl-Alt-F7 to get back
> to KDM, and try logging in again.

I keep this approach in mind in case I experience a similar problem.
The availability of several approaches to one problem is one of the
things I like about Linux.

>> ...... UNinstall and afterwords freshly reinstall .....
> It doesn't work that way in Linux. In Windows, when you uninstall and
> reinstall you are removing your user config files. Not so in Linux.

> ...unless you use --purge flag while uninstalling $sudo apt-get --purge remove somepacket
> or $sudo apt-get purge somepacket.....

I can imagine several situations in which such an approach could be useful.

Respectfully yours,


Bas G. Roufs M.A.
Van 't Hoffstraat 1
NL-3514 VT  Utrecht
M. +31.6.446.835.10
T. +31.30.785.20.40
BasRoufs at gmail.com

More information about the kubuntu-users mailing list