Sound only works with some apps, 8.04

Jonas Norlander jonorland at
Wed Apr 15 17:38:16 UTC 2009

On Wed, Apr 15, 2009 at 2:10 PM, Knapp <magick.crow at> wrote:
> On Wed, Apr 15, 2009 at 1:38 PM, Knapp <magick.crow at> wrote:
>> I am writing a game with python and panda3d. When I run the game from
>> the CLI, I get errors and the sound will not work.
>> :audio(error): _system->init(): Error initializing output device.
>> :audio(error):   FmodAudioManager is not valid, will use NullAudioManager
>> But when I run the same code from the programming editor Geany,  the
>> sound works and there are no errors.
>> There must be a setting somewhere that I need to fix for the command
>> line to work. Any ideas?
>> Thanks all!
> More info, it was not Geany that was doing the trick, it is that the
> first instance of the program locks up the sound so that the second
> one can not use it. How do I get them to share?

This looks like what used to happen when one used OSS for sound. I
don't have that problem anymore when all programs now using alsa. How
do you access the sound system?

/ Jonas

More information about the kubuntu-users mailing list