Fish won't work (long)

Tony Sivori TonySivori at
Sun Apr 12 17:19:51 UTC 2009

I can't get fish to work as described here:

Both computers run Kubuntu 8.04 with KDE 3.5.10. Identical usernames and
passwords. I enabled fish in Konqueror settings as described in the above
linked web page.

Ping works with zero packet loss between the two computers.

fish://@localhost works. 

fish://@<localhost's computername> does not work.

The computers are connected by wired Ethernet through a Lynksys WRTG54G2
wireless (wireless is disabled) router. I checked the router settings and
the only relevant setting I could find was "Filter Internet NAT
Redirection"  That setting is "OFF" (so according to the router help page,
NAT Redirection is Enabled).

Still,  I suspected the router might be filtering the protocol and or the
port. So I connected the two computers through a simple Netgear DS104 hub.
No change. Currently, the router is connected to the hub, and both
computers are going through the hub to the router.

Here's what else I've tried and the results:

Into Konqueror address bar:


An error occurred while loading fish://username@
Could not connect to host

I got the addresses from the routing table and ping works so I know they
are good.


An error occurred while loading fish://username@oldcomputer: Could not
connect to host oldcomputer.


An error occurred while loading fish://username@ Could not
connect to host

During my Googling I found sftp. So I tried that (in Konqueror), with this

An error occurred while loading sftp://username@ Unknown
Error encountered while talking to ssh.

Checked to see if ssh was installed. It didn't seem to be, so I did this:

sudo apt-get install ssh

and it installed ok.

Next try:

ssh: connect to host port 22: Connection refused

Unlike the rest of them, the above error was from a Konsole that popped
up, not from Konqueror.

Other things I've tried:

The "Share" tab on folders, I get this: "SMB and NFS servers are not
installed on this machine, to enable this module the servers must be

Then came the "Sharing" tab. "To share files via the web..." Applet
status: Not running.

I haven't tried to install any of those, as I thought they would be harder
than fish to get working, plus I do have personal data on these computers
and I'm concerned about inadvertently sharing it on the internet.

I've put hours in trying to make this work, with only negative results. I
could really use some help getting any kind of secure gui LAN working
between these two computers.

Tony Sivori
Due to spam, I'm filtering all Google Groups posters. 

More information about the kubuntu-users mailing list