Jaunty: Notifications

marc gmane at auxbuss.com
Sun Apr 12 17:00:10 UTC 2009

GreyGeek said...
> marc wrote:
> > .....
> > I want to use this thing, quite a lot, but man it's trying hard to make 
> > me walk away. But hey, maybe it'll all work by release day in a couple 
> > of weeks.
> >
> >   
> And yets untold numbers of folks, like me, are having EXCELLENT results
> with Jaunty.


> There could be any number of reasons why your success is lacking. Your
> ISO burn could be bad. Your hardware is not supported or is
> defective.

You don't seem to have read a word I wrote.

> You misunderstand prompts or get wild ideas about deviating
> from the install sequence and they don't work.


But sure, I often miss "notifications" ;-)

> You assume that Linux
> runs the way Windows does, but it doesn't.

You're the one doing the assuming (with brass knobs on and no returns). 

I work hard at introducing Linux to businesses that are Windows-only. On 
the server, this is becoming easier. As a starter, it's invariably a 
surprise to them to telnet into their router and show that they are 
running BusyBox. Makes it easier to introduce Smoothwall. Now, let's do 
that on Windows Server. Oh!

> Jaunty is not  an inanimate object.  It can't "try hard" to make you not
> like it.  You don't like it because you are not successful in trying to
> install it dual boot or as the sole OS (?) and so the problem can't be
> you, it has to be Jaunty.

Look, I'm sitting here in the depths of xorg.conf trying to figure out 
what the chuff Jaunty's done to my video card. I have working copies 
going back to badger (and etch before that) and I'm getting nowhere.

And yup, I'm in windows-land having to reboot, reboot, reboot. I thought 
those days were gone. (Okay, lucky I know about the insane Shuttleworth 
DontZap (sic) - can't believe he got that in upstream. Madness.)

When I find something, I'll raise/add it to a bug. Y'know, like us Linux 
folk do.

I don't even know if Jaunty is reading xorg.conf in any meaningful way. 
I have no confidence that it is doing what I expect.

This is because I couldn't get the preinstalled "Network manager" to do 
a damn thing, and when I checked /etc/network/interfaces I found that it 
wasn't being modified. What's that all about?

Removing "Network manager" and handcrafting interfaces had everything 
working in no time. So I have zero confidence that things behave as one 
would expect.

I guess you expect me to read through a zillion lines of c to see what 
it's doing, eh? Have you any idea what that takes?

And don't get me started on audio. Oh, okay, you have. OSS -> ALSA -> 
Pulse. What? Let's change the audio subsystem every year.

I have audio output, but what's going on with the mic? It's just a 
simple headset with green and pink plugs. How hard can that be? It's 
worked painlessly since etch, when I got the thing.

So, I run: cat /proc/asound/cards
and find my card. Then I run: cat /proc/asound/devices
to find the input. Not there? Run: alsamixer, obviously
to unmute it. And if that wasn't esoteric enough:

  arecord -c1 -Dplughw:0,0 -f cd -vv /dev/null

Hands up who knew about that? Can't wait to ask my mum to run that one!

Guess what? I have output, but only on 0,1 and 0,2. Obvious, really,

Now, why does the output sound like Mickey Mouse?

Yup, just like Windows.

I tell you, there's more problems with Jaunty than KDE4. But perhaps I'm 
the only unlucky one.


More information about the kubuntu-users mailing list