Please help me with DWA-120/130 on Wireless Networking

Nigel Ridley nigel at
Sun Apr 5 05:20:15 UTC 2009

Thinh Hoang Dinh wrote:
> Hello guys,
> I've spent days to get the wireless working on Kubuntu 9.04 beta, and I'm
> getting tired of it. I've followed the following steps:
> 1. Install ndiswrapper and ndiswrapper-utils.
> 2. ndiswrapper -i AGUx86.inf (AGUx86.inf here is a driver file of DWA-120).
> 3. ndiswrapper -m.
> 4. ndiswrapper -l.
> Everything seems fine, but when I ran iwlist -scanning, I could not find
> wlan0. Please help me out of this.

First do a 'lspci' (without the quotes). This will tell you which wireless card you have. It will 
be listed under 'Network controller:'.
Then do a 'sudo lshw -C network' (again without the quotes). This will let you know which drivers 
you are using.

If it is indeed an Atheros, then there is no need for ndiswrapper as there is a good open-source 
driver. The same is true for the Broadcom cards as well (in Jaunty and also updated Hardy and 

I tried for 2 weeks (on and off) to get my wife's Broadcom to work and eventually figured out 
that I had pressed the 'hot keys' (Fn F11 on a Dell Vostro) and had switched the wireless off! 
You might have a physical switch on your laptop -- make sure that it is switched on.



More information about the kubuntu-users mailing list