Kaffeine Problem - Fix didn't work

Michael Satterwhite michael at weblore.com
Fri Oct 31 21:50:21 GMT 2008

On Friday 31 October 2008 15:28:47 Knapp wrote:
> On Fri, Oct 31, 2008 at 9:04 PM, Nigel Henry
> <cave.dnb2m97pp at aliceadsl.fr> wrote:
> > On Friday 31 October 2008 17:42, Michael Satterwhite wrote:
> >> I'm trying to play a DVD and getting an encryption error message. The
> >> message says that I need to run 'sudo
> >> /usr/share/doc/kaffeine/install-css.sh" - which I have done. Even after
> >> running this, I still get the encryption error.
> >>
> >> Can anyone suggest a fix?
> >
> > This problem with Kaffeine was discussed a while back, and I did get
> > Kaffeine working on my Hardy heron install. You need to make sure that
> > you have the libdvdcss2 package installed, so that encrypted DVD's can be
> > decrypted. Even after installing the package you may still get the above
> > message, which is misleading as to the actual problem. You can get
> > libdvdcss2 from the medibuntu repo, details below if you dont have it in
> > /etc/apt/sources.list.
> >
> > Go to http://help.ubuntu.com/community/Medibuntu , and add the repos for
> > your as directed for your Kubuntu version.
> >
> > Then do an apt-get install medibuntu-keyring , which will install the GPG
> > key for the repo.
> >
> > I got my Kaffeine playing DVD's, after installing libdvdcss2, by renaming
> > the ~/.xine file, and restarting Kaffeine, which then created a new .xine
> > file. Saying that though, I may have had to do that a couple of times, as
> > I see I have 2 backups for .xine, and possibly rebooted as well. I
> > remember having to go through the hoops a bit, to get Kaffeine working
> > with DVD's.
> >
> > Something else I remember from the earlier kaffeine thread, was to do
> > with Kaffeine not finding the optical drive, which is why the error
> > message displayed. My Kaffeine >Settings > xine Engine Parameters >media,
> > shows the dvd device as /dev/dvd. Have a look in /dev, and see which
> > block device /dev/dvd is pointing to. Mine in Hardy Heron is pointing to
> > scd0, which is correct.
> >
> > That will do for now. Post back please.
> >
> > Which Kubuntu version have you installed, and was this an upgrade, or a
> > fresh install?
> >
> > All the best.
> >
> > Nigel.
> All what has been said was true but it was only a patch. The end
> solution was this and it is very easy to do, IF this is your problem.
> If not it is easy to undo this fix too and get back to us. The rest is
> a repost:
> The best thing to do is leave all those packages the way they were at
> first and just remove
> (rename it to something else with the word backup is better) the file
> called
> /etc/udev/rules.d/70-persistent-cd.rules
> Then reboot your computer.
> All should now be working. It also will prevent any future problems
> and will make ALL the software work.

I saw both of your posts at once, so I hadn't made the first change. I did 
rename the file as you suggested and rebooted. I *DO* have libdvdcss2 
installed (I just check Adept to be sure). After the reboot, I tried to play 
the DVD again, and again got the message "This DVD is encrypted, ,,," again.

More information about the kubuntu-users mailing list