ISP caching and updating

Willy K. Hamra w.hamra1987 at gmail.com
Fri Oct 31 01:13:21 GMT 2008


I started noticing a problem with issuing aptitude update about a month
ago. i issue the command, and try to install a package, to get a 404
error. i manually check the files in the repos to discover that aptitude
is trying to download an old version of a package that is no longer
available. so i suspected a lag in the mirror or something (was using
the main repo), i changed my mirror, and updated, everything worked
fine. but a week later, the problem came back. i tried to watch the
"sudo aptitude update" output, and found that it's hitting and ignoring
loads of stuff, meaning that these are unchanged, so i changed my mirror
again, and everything worked fine. but today, is my third change of the
mirror, and this is starting to annoy me. after some thinking, i know my
ISP uses Squid caching, i see it's error messages a lot when browsing,
and i think it's caching the package lists, that's why aptitude is only
hitting them. what can i do about it? usually, when i want to skip the
cache for some site, i use https (if available by website), is there a
way i can use a secure connection for aptitude? or some other way to go
around this problem?
thanks in advance


-- 
Willy K. Hamra
Manager of Hamra Information Systems
Co. Manager of Zeina Computer & Billy Net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: w_hamra1987.vcf
Type: text/x-vcard
Size: 129 bytes
Desc: not available
Url : https://lists.ubuntu.com/archives/kubuntu-users/attachments/20081031/a87e819e/attachment.vcf 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 260 bytes
Desc: OpenPGP digital signature
Url : https://lists.ubuntu.com/archives/kubuntu-users/attachments/20081031/a87e819e/attachment.pgp 


More information about the kubuntu-users mailing list