Sound problem in Kubuntu 8.10

Nigel Henry cave.dnb2m97pp at aliceadsl.fr
Thu Oct 23 19:03:34 BST 2008


Hi Bas. Welcome to the sound problems club. Suggestions below.

On Thursday 23 October 2008 17:08, Bas Roufs wrote:
> Dear everybody
>
> Already for more than 1 year I have been trying to access my sound
> card in my PC - first via Kubuntu 7.10, today via Kubuntu 8.10. But
> still no sound at all!
> I have tried to follow the instructions at this page:
> http://ubuntuforums.org/showthread.php?t=205449
> This is the so-called 'Comprehensive sound check Problem Solutions Guide'.
>
> At the Windows partition, the sound works OK - so there is no hardware
> problem. Moreover, Linux does recognise my sound card. The terminal
> command lspci -v delivers -amongst others!- the following result:
> (....)
> 00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6
> Family) High Definition Audio Controller (rev 05)
>         Subsystem: Hewlett-Packard Company Device 2a28
>         Flags: bus master, fast devsel, latency 0, IRQ 16
>         Memory at ffa3c000 (64-bit, non-prefetchable) [size=16K]
>         Capabilities: <access denied>
>         Kernel driver in use: HDA Intel
>         Kernel modules: snd-hda-intel
>
>
> (....)
>
> Here I see the first strange thing:
> " Capabilities: <access denied>".
>
> Could this (partly) explain the problem I am dealing with?

No. To see the capabilities, you have to run lspci as root (eg: sudo lspci -v)
>
> Via this page:
> http://www.alsa-project.org/main/index.php/Matrix:Module-intel8x0
> ... I found out that needed to install the driver 'intel8x0'.
> I have done in the ways suggested by the '.... Solutions Guide'....
>
> Can anyone  give me a clue what to do next?
>
> Thanks for your repy.
>
> Bas Roufs.

I havn't got Intrepid 8.10 installed, but do have both 7.10, and 8.04 on one 
of my machines, which uses an hda intel soundcard, and the sounds work ok. 
Saying that though, there are many, many different versions of this card, 
using different codecs.

The first question is, is this a laptop, or PC, and make, and model please.

Do you have any usb devices which are sound related plugged in? For example, 
webcams, usb midi keyboards, etc. If so remove them temporarily.

Do you get any output from the following commands? (all run as user)

cat /proc/asound/version
cat /proc/asound/cards
lsmod | grep snd

Post back, and we will see how this goes. I'm not a sound guru, but have 
helped out from time to time.

Nigel.



More information about the kubuntu-users mailing list