latest update needs ridiculous new packages

Willy Hamra w.hamra1987 at gmail.com
Fri Oct 10 18:59:39 BST 2008


2008/10/10 Derek Broughton <news at pointerstop.ca>:
> Willy K. Hamra wrote:
>
>> Derek Broughton wrote:
>>> Willy K. Hamra wrote:
>>>
>>>> can someone tell me why the latest update requires the installation of
>>>> some new packages like bluetooth? i don't have bluetooth, don't have BT
>>>> dongle, a BT phone, or anything related to it!
>>>> mobile-broadband-provider-info, i don't even USE a mobile!
>>>> not to mention libgweather1 , BAAH!
>>>
>>> That's not the "latest" update.  Hardy installed bluetooth, and iirc, so
>>> did
>>> Gutsy.  It's just because kubuntu-desktop depends on everything the
>>> developers think you're likely to need.  Feel free to remove them (and
>>> kubuntu-desktop with it).  kubuntu-desktop will then get added back
>>> before upgrading to the _next_ release, if you use the adept updater.
>>>
>>> libgweather1 seems odd though - isn't that a gnome library?
>
> Yes, it is.  It _really_ shouldn't be part of a Kubuntu install, but it's
> possible you have some gnome component that is now requiring it.
>>
>> i forgot to mention, i'm using kubuntu intrepid.
>> i don't know if these were installed in previous versions, but in the
>> latest update of intrepid, they are now showing in  aptitude as new
>> packages!
>
> Sure, because if you upgraded through the adept updater, it added
> kubuntu-desktop back in, and that forced it to load Bluetooth, etc.  You
> can just remove them, but if you use the approved upgrade path, they'll
> come back again next upgrade.

But kubuntu-desktop has been installed ever since i did the fresh
install of intrepid about a month ago. i always had kubuntu-desktop,
and i'm sure these new packages weren't installed, or had any similar
package installed so they can replace it. they are new dependencies.
as for GNOME, i don't have it, but i do have some GNOME packages
installed, i think i should check and see what packages require all
these weather packages. libgweather1 is only one of the new packages,
there is a few dozen new similar packages to be installed.

-- 
Willy K. Hamra
Manager of Hamra Information Systems
Co. Manager of Zeina Computers and Billy Net.



More information about the kubuntu-users mailing list