wireless help!

D. R. Evans doc.evans at gmail.com
Mon May 5 08:26:09 BST 2008

2008/5/4 Jason Straight <jason at jeetkunedomaster.net>:
> On Sunday 04 May 2008 12:02:15 D. R. Evans wrote (Reply at bottom):
> > I've messed with kwifimanager (GUI) and iwconfig (CLI) until I'm blue
>  > in the face. Of course it worked first time with Vista :-(
>  What type of wifi card? 'lspci' should show you the details of the
>  manufacturer/chipset.

It's a realtek chip accessed through ndiswraspper (I started a thread
about that and which contains details on 27 March).

>  iwconfig doesn't really do anything with WPA, for that you need WPA
>  supplicant, it's not a lot of fun to do the first time but that's why there's
>  kwifimanager, which configures and runs wpa_supplicant for you.
>  I'm not sure why kwifimanager didn't work, but that would be the route you'd
>  want to take. It may be the key you're using, I had problems once with I
>  think AES with WPA2, going back to WPA1 worked fine. Although that's not the
>  cure you really want it might be the one that gets you up and running with
>  the least fuss for now, and it will also verify that WPA1 works and WPA2 is
>  the problem.

What happens in kwifimanager is that when I type in the key in the
"Configure Encryption" dialogue, it just says "unrecognised". It
doesn't seem to matter what 8 characters I type, it always says the
same thing.

I've tried using wpa_gui, but it doesn't seem to do anything useful at
all. It just sits there. Even the Contents and Index of the Help menu
are greyed out, while the console fills with messages that say "PING
failed - trying to reconnect".

There is an "Add Network" command in the File menu of wpa_gui that
seems to be the place where one can add the encryption information,
but it asks for all kinds of stuff that I don't know. The access box I
have simply gives me an 8-character access key. I deduced from Windows
that it the system is using WPA2, but I have no way to know if that's
true, and I certainly can't change it at all (anent your suggestion of
using WPA1; if it were up to me, I'd turn off crypto entirely, it's
just too much hassle on this laptop when running gutsy). All the box
has on it is:
  1. The SSID
  2. The eight-ASCII-character "Network Key"
That seems to be enough for Windows to work out what to do to access the network


More information about the kubuntu-users mailing list