corrupted file removal

James Gray james.gray at
Tue Mar 18 21:00:18 UTC 2008

Fred Schuelzky wrote:
> James Gray wrote:
>> On 18/03/2008, at 12:24 PM, Fred Schuelzky wrote:
>>> The other nite I tried to install goggleearth from the medibuntu site.
>>> At the EULA, yes or no prompt I became confused or crs hit me.  Now  
>>> I am
>>> unable to use update mgr.  Snyaptic gives me this message  E:
>>> goggleearth: Package is in a very inconsistant state - you should
>>> the error message stops there,  i should what?
>>> Any ideas on how to remove this corrupted package
>> Try on the command line (xterm/gterm/etc):
>> sudo apt-get -f remove
> James thanks a million!  Your fix got me fixed.  I thought we were going 
> to remove the package  the sudo apt-get -f remove command actually 
> reinstalled the package.
>  When I tried the  update manager it actually  updated  googleearth to 
> the latest version.
> I sure appreciate your help

No problem Fred.  Glad it all worked out for you.  The main goal with 
the "apt-get -f ..." is to get your package manager into a sane state. 
After that you can add/remove whatever you like.  To be honest, I've 
only used "-f install" when recovering from broken installs, not 
removals.  I just assumed "-f remove" would reverse the 
logic...apparently not :P  Serves me right for not testing it before 
making assertions - heheh.

Anyway, thanks for letting us know your system's back to normal.  It's 
nice to know the community still works :)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3253 bytes
Desc: S/MIME Cryptographic Signature
URL: <>

More information about the kubuntu-users mailing list