dpkg error

Nigel Ridley nigel at rmk.co.il
Fri Jan 18 20:30:25 GMT 2008


Derek Broughton wrote:
> Nigel Ridley wrote:
> 
>> I just installed a package on my daughter's Feisty box and whilst doing
>> so, apt gave a message about unneeded packages which I could remove with
>> 'apt-get autoremove'. The list included a bunch of games and linux
>> headers. I took note of the games (so as to install them again - I wasn't
>> sure if there were newer new-named packages or not) and didn't worry about
>> the linux headers package as I have an older kernel installed - so I did
>> as suggested.
>> Everything was going OK until apt got to the linux headers and
>> complained about not being able to remove a makefile inside the /nfsd
>> dir - permission denied.
>> I tried again after booting into the older kernel - no joy!
>> I tried as root from the older kernel rescue mode - apt complained that
>> it couldn't execute dpkg!
>>
>> I tried rebooting into the normal older kernel and now am stuck with:
>> Could not exec dpkg!
>> E: Sub-process /usr/bin/dpkg returned an error code (100)
>>
>> Any ideas? I can't install or remove anything at the moment.
> 
> Go back to the correct kernel, fix the permissions on the nfsd directory,
> and try again.
> 
> Why would you boot into a different kernel, when the answer was given to you
> in the first try?

Tired? Also because I figured it was because I was using that kernel and that's why it was 
being 'blocked'.
But why would the permissions on the nfsd directory change?
And what is the problem with dpkg?:
E: Sub-process /usr/bin/dpkg returned an error code (100)
I tried searching Google for the exact eror message but didn't find an 'error code (100)'.

I'm back off to work again - so I'lll try things tomorrow.....

Blessings,

Nigel

-- 
OliveRoot Ministries
http://www.oliveroot.net/

PrayingForIsrael.net
http://www.prayingforisrael.net/





More information about the kubuntu-users mailing list