Problems Moving To amd64

Daniel Pittman daniel at
Sat Feb 9 09:10:39 UTC 2008

"Graham Todd" <grahamtodd2 at> writes:

> Before I changed my computer to an amd64 from an AMD Athlon+, I copied
> my /usr and /home partitions to an external hard drive.
> When I tried to copy the data over, I found the directories had been
> kept, but not the files; even the directories are empty!  It was
> galling to find my gnupg infomation, my mailfilter rc file, and my data
> from Kmail and Claws-Mail was missing...
> So I tried copying the data to DVDs, and when that was not recognised,
> I tried copying a limited number of files alone, and none appeared on
> the amd64 machine.
> Is this a known problem and does anyone know what is the solution?  

This is not a common problem, and not the sort of problem that is
usually encountered.  

How did you copy the files to the external hard drive?  What file system
was the target disk?  How about the DVD?

> Is it something silly I've done?

Perhaps, perhaps not.  Until we know what you have done we can't

> I can't just move the drives from one machine to another as the
> Athlon+ drives are IDE and the amd64 drives are SATA.  Other than
> that, any help would be appreciated.

Try creating a 'tar' file containing your files, stored on the external
drive, and then unpacking that in the right place on the new machine.

However, one note: the applications in /usr will not really be useful on
the new system, although it may be worth hanging on to if you have
written your own software in /usr/local, etc.

Daniel Pittman <daniel at>           Phone: 03 9428 6922
1/130-132 Stawell St, Richmond              Web:
Cybersource: Australia's Leading Linux and Open Source Solutions Company

More information about the kubuntu-users mailing list