7.10 won't recognize my usb turntable

Eric ejazzkatt at gmail.com
Sun Apr 13 17:44:36 UTC 2008

Fred Schuelzky wrote:
> Eric wrote:
>> D. Michael McIntyre wrote:
>>> Audacity is probably good enough for your purposes, but if you want to play 
>>> records live, I can't think of a likely way to do that unless you use JACK to 
>>> route the audio input from the record player to the audio output on whatever 
>>> soundcard you normally use.  (Well, unless you use a physical audio cable to 
>>> connect them, if that is an option.)
>> I have the same turntable and the same problem. The turntable comes with 
>> Audacity for both Windows and Macs. It even has a printed manual for 
>> Audacity.
>> The turntable also allows you to hook it up to your computer in the same 
>> way you hook up any other turntable to a PC. Using that method, I have 
>> been able to use Audacity. This method required a pre-amp
>> Eric Jackson
>>> JACK is a pretty huge subject, and I would encourage you to seek out the 
>>> Ubuntu Studio Users list, or the Linux Audio Users list for further help with 
>>> that.  First, I would encourage you to just get started with Audacity, and 
>>> see what happens from there.
>>> Good luck
> Eric
>     I was under the impression that the Numark TTXUSB has a built in 
> preamp. It has a gain control on the panal where you plug in the audio 
> cables / usb cable.
> Appreciate the input.
> Fred

Oh I guess I have a different model. My turntable is a Newmark TTUSB (no 
x). It's the cheaper model.

I don't have 7.10 installed. I have 6.06 LTS installed. I just tried it 
again. Success! It worked.

I also have a USB music keyboard. I can't remember if I read this about 
the keyboard or the turntable but with one of them, the device had to be 
plugged in and turned on when you booted up. My computer wouldn't 
recognize them if you plugged it in after booting.

In Audacity, my input is "line" I went to Audacity's preference and 
selected Audio I/O. There were two choices listed under both Playback 
and Recording. The default didn't work for recording so I selected the 
other choice and it recorded. My playback and my record devices are 
different. Also in Preferences on the I/O page I selected to have the 
sound playback while recording. I clicked on the monitor switches. 
That's it. It recorded.

Eric Jackson


More information about the kubuntu-users mailing list