kmail refuses to check for new mail

Derek Broughton news at pointerstop.ca
Fri Sep 28 00:39:18 BST 2007


Donatas G. wrote:

> Strange thing: when I use a 3G modem to connect to internet in my laptop
> and not wireless/wired network connection, kmail refuses to check for new
> mail...

I wouldn't say it's a "strange" thing.  But it's a damned annoying one.  It
appears to be intentional, and related to Network Manager, and the "network
status daemon" and possibly the "DNS-SD Service Watcher".  They're  b0rked,
and I haven't seen any indication that there's a plan to fix this.

> Or rather, once I push "Check Mail On" button, the status bar of Kmail
> says: "Sending finished. No new letters". This happens on imap account
> that I know does have a lot of new mail, 

In KMail, I suspect it's _specifically_ related only to IMAP folders.  Since
all my mail is on the local IMAP server, so I shouldn't need _any_
interfaces up, that's infuriating.

> How do I troubleshoot that? Could that be some new feature of kmail, that
> it checks mail only when some network interface is up (and programmers
> forgot about ppp0)?

Yes.  That's exactly true.  

> The same strange behaviour was noticeable in Konqueror - it would say a
> webpage is not reachable at once without even trying (firefox opened pages
> fine). 

Yes, same error.

> This behaviour stopped when I disabled usage of cachee for 
> Konqueror.

Oh?  That's news to me.  Thanks.
-- 
derek




More information about the kubuntu-users mailing list