Database Locked - Adept Crashes

Brad Opferman bardo88 at gmail.com
Thu Oct 25 00:59:12 BST 2007


This problem is coming from multiple processes simultaneously running 
that are using the update database. I usually get this problem if I try 
to update or install something on the command line while I already have 
synaptic or adept open. Try doing a ps -ef | grep adept and killing the 
processes that it has spawned. I remember there being a setting 
somewheres to how to stop it from starting automatically but I cant 
recall its location. Try killing the processes associated with adept and 
if that doesnt work, try searching for synaptic processes if you have it 
and killing those.

Brad


Ronnie Tucker wrote:
> Hi all, this is a weird problem that's come right out of the blue...
>
> If I try to load up my Adept I get:
> Database Locked - Another process is using the packaging system
> Resolve Problem? Yes/No/Cancel.
>
> If I choose Yes it crashes with the message:
> Signal 6 (SIGABRT)
> and if I click the Backtrace tab I get:
> 'Backtrace appears to be if no use.'
>
> I loaded up KSysGuard and I seem to have:
> adept_notifier - running under my user name
> adept_updater - running as 'root'.
>
> adept_updater seems odd as I'm already running a bang up to date Gutsy   :/
>
> I tried rebooting the PC but everything is still as above.
>
> Assuming adept_updater is my my problem, how can I stop it loading at boot?
>
> Thanks in advance!   :)
>
>   




More information about the kubuntu-users mailing list