Compiz slow, no effects (Gutsy with ATI X1400)

Michael Bach (gmx) bach.michael at gmx.net
Fri Oct 19 19:39:15 BST 2007


Dotan Cohen wrote:
> On 19/10/2007, Michael Bach (gmx) <bach.michael at gmx.net> wrote:
>> Dotan Cohen wrote:
>>> I have a Dell Inspiron 6400 / E1505 with the ATI X1400 video card and
>>> 1680x1050 resolution widescreen LCD. With the ATI driver I was able to
>>> run Beryl at the native resolution with Kubuntu 7.04 (KDE desktop).
>>> Now that I have upgraded to Gutsy, Compiz is very slow and has no
>>> graphical effects.
>> With the update you have performed, did you carry over your xorg.conf
>> from the previous kubuntu to gutsy, or did you have gutsy automatically
>> generate a new xorg.conf?
>>
>> Mike
>>
> 
> I did not update, this was a fresh install. However, I could not
> configure the proper screen resolution, so I salvaged xorg.conf from
> the feisty backup tarball.
> 
All right.
I was asking because I have seen two xorg.conf's from gutsy (my T23 and 
a Panasonic Toughbook) so far, both without sections "Modules", 
"Extensions" and "DRI". So this is something that has changed in the 
x-server.

Maybe you could get back on the road by getting a basic xorg.conf 
generated automatically (taking care of inputs and graphics card) and 
then manually editing to fit your screen in:

Automatic xserver configuration is done by:
"sudo aptitude -phigh xserver-xorg"
(I hope I got it right this time :)

Then overwrite the section "Monitor" (only this one) in the new 
xorg.conf with the same section from  the old xorg.conf. Or just edit 
the figure in the new xorg.conf to what they are in the old xorg.conf.

Mike



More information about the kubuntu-users mailing list