need to unplug USB drive

Nigel Ridley nigel at rmk.co.il
Sat Nov 3 19:11:22 UTC 2007


Sylviane et Perry White wrote:
> On Thursday 01 November 2007 16:36, Nigel Ridley wrote:
>> This might help:
>>
>> I stuck dsl-n (Damn Small Linux - not) Live CD in the laptop, mounted
>> the USB drive, changed the 'group' ownership to 'users' (keeping the
>> 'user' as root), added myself to the group 'users' on my Kubuntu box
>> (logged out and back in again - for the group change to take effect) and
>> now I can write to the USB drive on both the laptop and the Kubuntu box
>> (and I suppose, any Linux box as all distros have the group 'users' as
>> standard - just need to be added to group 'users').
>>
>> Blessings,
>>
>> Nigel
> 
> Summary:
> Second user (the one that didn't plug the stick in) couldn't write to a USB 
> stick, nor unmount it.
> 
> Thanks Nigel.
> 
> I tried that, *but without the dsl-n live CD* and I wasn't allowed to change 
> the group ownership of the stick.
> 	sudo chgrp users /media/usbdisk   ---> "Opération non permise"
> Actually I couldn't even change the group ownership of a single file on the 
> stick, although the same syntax worked for a folder belonging in the 2nd 
> user's home.
> 
> Having read something in 
> http://www.yolinux.com/TUTORIALS/LinuxTutorialManagingGroups.html ,
> I also modified group in /etc/fstab, to no avail.
> Btw under Suse 9.3 the stick gets mounted with group users, and there not even 
> a line for it in fstab.
> 
> Why did you use dsl-n, it is hard for me to belive it is (or any live CD) an 
> essential component of your manipulations.
> Did I miss something else?
> 
> Greetings		Perry
> 
> 
> 
> 

I used the dsl-n live Cd because I couldn't get Kubuntu to change 
permissions - I think it has something to do with the automagical mount 
thingy. The live Cd's use a manual mounting system (I couldn't even 
format and create partitions using qtparted on Kubuntu because the 
device must be unmounted - but when it is unmounted there is no record 
of it either in fstab nor mtab!).

I reformatted my USB stick into 3 partitions - a linux swap (for use 
with dsl-n); a [large] ext2 partition and a fat16 partition.
On Kubuntu the fat16 partition was mounted as user 'nigel' and group 
'root' - so no problems writing to it.
The problem was gaining write permission to the ext2 partition - which 
is why I needed to change group ownership to 'users' and add myself the 
the group 'users' on the Kubuntu box.

In summary - there is something wrong with the way Kubuntu assigns 
permissions to native linux filesystem USB devices using this newfangled 
automagic mounting system.

Blessings,

Nigel

-- 
OliveRoot Ministries
http://www.oliveroot.net/

PrayingForIsrael.net
http://www.prayingforisrael.net/







More information about the kubuntu-users mailing list