Amarok and Creative Zen V mp3 players

Donald Allwright donald_allwright at
Mon May 7 18:37:38 BST 2007

Message: 3
Date: Mon, 7 May 2007 14:15:09 +0200
From: manchicken <manchicken at>
Subject: Re: Amarok and Creative Zen V mp3 players
To: kubuntu-users at
Message-ID: <200705071415.10044.manchicken at>
Content-Type: text/plain;  charset="iso-8859-1"

On Monday 07 May 2007 13:44:19 Richard Hambleton wrote:
> On 5/4/07, Donald Allwright <donald_allwright at> wrote:
> > I've been trying for ages to get my Creative Zen V recognised in
> > way or other by my Kubuntu system, so far without success. I've
> > the following lines to /etc/udev/45-libnjb.rules:
> >
> > # Creative Zen V
> >  SYSFS{idVendor}=="041e", SYSFS{idProduct}=="4150",
> > MODE="0660"
> > # Creative Zen V Plus
> >  SYSFS{idVendor}=="041e", SYSFS{idProduct}=="4152",
> > MODE="0660"
> >
>What libraries did you also install in the process of installing

When I wrote my original mail, I had tried Gnomad2 but without success.
However, it seems to have started working now so that might have been a
blip. Looking into the libraries I have libnjb5 version
2.2.5-4.1ubuntu2 and libmtp5 version 0.1.3-0ubuntu2. The creative Zen V
seems to be supported in libmtp from version 0.1.4, however it may be
that the only relevant changes are those to the udev configuration
which I have applied manually, so this is why it's now working in
Gnomad2. Still no joy with Amarok though. Typing:

 ldd `which amarok` | grep mtp

returns no results, so I think Amarok must have its own mtp support
built in rather than using libmtp. It may be that it lacks something
required by the Zen V? Amarok version is 2:1.4.5-0ubuntu7+medibuntu1,
the version from the medibuntu repository that is built with mtp
support (among other things).


43 - slightly more than the answer to life, the universe and everything.

Yahoo! Answers - Got a question? Someone out there knows the answer. Try it

More information about the kubuntu-users mailing list