Failed to list files in /camera

Jim MacLeod snap.dragon at blueyonder.co.uk
Wed Mar 14 17:35:42 GMT 2007


Peter Ulrich wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Jim MacLeod wrote:
>> Binary package hint: libgphoto2-2
>> The file /etc/udev/rules.d/45-libgphoto2.rules says in line 3:
>> BUS!="usb*", GOTO="libgphoto2_rules_end"
>> [...]
>> SUBSYSTEM!="usb_device", GOTO="libgphoto2_rules_end"
>> instead would work.
>> 
> 
> Didn't help. It's really mysterious. Instead of connecting the camera
> directly via USB I tried to read the card via my card reader - result
> (error message): Failed to list files in/sdd1.
> 
> The mystery for me is that Digikam always worked correctly with this
> camera and this computer - also under a former SUSE installation and
> under the former Ubuntu/Kubuntu installation. There are no faults in
> camera or computer: all components are working correctly under Windows
> XP (used for playing MS TrainSimulator).
> 
> Peter

Just tried it with my CX7430 and it worked but I only changed BUS to
SUBSYSTEM ie. I left "usb*" as it was, so maybe this is would help.

I think the problem was in the last upgrade on 11th March so you could
revert back to the previous packages - (I use Kubuntu) - which worked for
me before I found this other method

Aptitude 0.4.1: log report
Sun, Mar 11 2007 16:27:09 +0000

Will install 3 packages, and remove 1 packages.
410kB of disk space will be freed
===============================================================================
[REMOVE, NOT USED] libusb-dev
[DOWNGRADE] libgphoto2-2 2.3.0-0ubuntu3~edgy2 -> 2.2.1-2ubuntu4
[DOWNGRADE] libgphoto2-2-dev 2.3.0-0ubuntu3~edgy2 -> 2.2.1-2ubuntu4
[DOWNGRADE] libgphoto2-port0 2.3.0-0ubuntu3~edgy2 -> 2.2.1-2ubuntu4

HTH

Jim




More information about the kubuntu-users mailing list