Can't get DHCP IP, may be avahi related

J. Pablo Fernández pupeno at pupeno.com
Tue Jun 26 18:50:58 BST 2007


Hello Kubuntuers,
I am experiencing strange problems. I have two notebooks running Kubuntu which 
have problems getting an IP by DHCP. I've experienced the same issues in 
three different networks, two wlans and one corporate lan with hundreds of 
other computers just working (some Windows, some Mac OS X and some Linux).
Basically the sympthon is that I don't get any IP address. eth0 has no IP(v4) 
address and there's an eth0:avahi (virtual?) device with a private IP. Now, 
with enoughs restarts and ifdown ifups I get an IP. I can be 100% sure but it 
seems that whenever I get an IP the eth0:avahi interfare is not present... I 
am starting to be suspicious of this avahi thing.
At the corporate network, when I finally get an IP address, it still doesn't 
work. Now the sympthon is that I can ping the nameservers but they don't 
reply to any DNS query. Fair enough, let's see what's going on... a tcpdump 
doesn't show anything... and I am not talking about DNS, not even the pings 
are shown, and when I cancel it (^C) I get this:
$ tcpdump
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
18:29:54.910460 arp who-has 172.26.128.68 tell 169.254.9.96

1 packets captured
495 packets received by filter
148 packets dropped by kernel

Why are there packets dropped? I don't have any firewall in place, my iptables 
are empty.
If I keep ifdowning/ifuping, eventually it works, but it takes a lot of tries.

Furthermore, my routing table seems to have some remains of this avahi thing:
$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
172.28.3.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
0.0.0.0         172.28.3.254    0.0.0.0         UG    0      0        0 eth0

but I don't have the avahi thing anymore so I don't have any IPs in the 169... 
network:

1: lo: <LOOPBACK,UP,10000> mtu 16436 qdisc noqueue
    inet 127.0.0.1/8 scope host lo
2: eth0: <BROADCAST,MULTICAST,UP,10000> mtu 1500 qdisc pfifo_fast qlen 1000
    inet 172.28.3.205/24 brd 172.28.3.255 scope global eth0

Isn't it invalid to have such a route? I've tried deleting it, maybe I've got 
the syntax wrong, but I couldn't do it:

pupeno at silver:~$ sudo route del 169.254.0.0
SIOCDELRT: No such process

Any ideas what's going on and/or how to fix it? Anyone experiencing something 
similar?

Thank you
-- 
J. Pablo Fernández <pupeno at pupeno.com> (http://pupeno.com)



More information about the kubuntu-users mailing list