Lost all alsa sound - Thinkpad X60, 7.04

dimitris dimitris at gmail.com
Fri Jun 22 01:33:59 UTC 2007

After a resume, my 7.04 system has lost all alsa/PCM sound.  The only
sounds that work are the "system" sounds, i.e. the AC adapter
connect/remove and, when in console (but not KDE), the bell.

I haven't changed/upgraded anything and the sound works under WinXP.

KMix looks normal, not muted, as does alsamixer.  The system volume
(this is a Thinkpad X60) is also not muted.

I did get a BIOS "nvram checksum" error on reboot a couple of days ago,
and I wonder if that has something to do with it.  As I said above
though, XP is having no problem playing PCM sound...

I've tried rebooting, including a complete poweroff/remove AC/remove
battery/restart cycle, but sound is still broken.

I've also tried to dpkg-reconfigure alsa-base, but it doesn't have any
effect (and doesn't complain either).

In case it's relevant, if I try to play anything with 'aplay' I get:

ALSA lib pcm_direct.c:867:(snd_pcm_direct_initialize_slave)
snd_pcm_hw_params_any failed
ALSA lib pcm_dmix.c:876:(snd_pcm_dmix_open) unable to initialize slave
aplay: main:550: audio open error: Invalid argument

Any ideas?


More information about the kubuntu-users mailing list