Could not connect to host (port 8080).

Derek Broughton news at
Wed Jun 13 00:28:17 UTC 2007

Wilfried Kaeufler wrote:

> Derek Broughton schrieb:
>> Phil Pinkerton wrote:
>>> It seems like a simple problem but for the life of me I cannot remember
>>> how to fix it.
>>> I installed Oracle-XE the DB is running but port 8080 is not active.
>> First guess is you have something else on 8080.  Try "telnet localhost
>> 8080".
>>> Started with pid=5715
>>> Listening on:
>>> Listener completed notification to CRS on start
>>> 11-JUN-2007 07:48:29 *
>>> (CONNECT_DATA=(CID=(PROGRAM=)(HOST=quecaixa)(USER=oracle)
>>> * status * 0
>> That looks a little odd.  Why does the listener specify
>> ""
>> but the connect says "HOST=quecaixa"?  Try making it just "localhost"
>> (mine is actually Even if you actually want to connect from
>> another host, _you_ connect to the listener, and _it_ connects to the
>> database, so if the listener runs on the same machine as the db it
>> doesn't need a network name (well, I'm a bit out of my depth, but I run
>> Oracle XE on my laptop and _do_ access it from SQLDeveloper and Toad from
>> another box).
> I think, your problem is the tcp-port 8080 for https reserved for the
> localhost-

Why do you think that?  8080 is not usually used for https and afaict
nothing he's doing is trying to use https.
> Take another host: e.q. 8088 or 6588 etc.

hmmm.  Never tried using another host on 127.0.*.*.  That might well work -
but again, the real problem appears to me to be that he _isn't_ using a
local IP, he's using quecaixa or
> But donĀ“t use the tcp/ip ports: 80, 8080, 21, 2121, 100, 1010.
> Use anothr protocol than tcp/ip.

Ack!!!  That's never going to work.  You want to use 8080 because it's
generally easier to make _anything_ else use another port than Oracle, and
you MUST use TCP/IP (well, there might be a work-around, but I sure don't
know it).

More information about the kubuntu-users mailing list