Getting Audacity to work

Dexter Filmore Dexter.Filmore at gmx.de
Fri Jul 20 09:40:53 BST 2007


On Thursday 19 July 2007 15:07:34 Tim M wrote:
> I am trying to edit some long recording using Auductiy BUT I keep getting
> an error message saying: Error while opening sound device. Please check the
> ouput device settings and the project sample rate. Well, I have lowered the
> sample rate to 16 and still get the same error. My sound system is working
> fine. Does anyone know what the problem with Auducity might be OR lead me
> to an audio editing software that works?
> tm

Usually this means some other app is hogging the sound card.
Open a console and run 
$ lsof | grep dev 
and see if something suspicious turns up.

If not, strace audacity:

$ strace -o aud.trc audacity

and after you got the error message, close audacity.
Then have a look at that trace, especially "open" calls:

$ grep -i open aud.trc | less

Search in there for "dev" occurances and see if they look like they should.

Do you have more than one sound card? ran asoundconf? is oyur sound hardware 
capable of hardware mixing?

Dex


-- 
-----BEGIN GEEK CODE BLOCK-----
Version: 3.12
GCS d--(+)@ s-:+ a- C++++ UL++ P+>++ L+++>++++ E-- W++ N o? K-
w--(---) !O M+ V- PS+ PE Y++ PGP t++(---)@ 5 X+(++) R+(++) tv--(+)@ 
b++(+++) DI+++ D- G++ e* h>++ r* y?
------END GEEK CODE BLOCK------

http://www.stop1984.com
http://www.againsttcpa.com



More information about the kubuntu-users mailing list