id-static: final link failed : No space left on device - Solved!

Nigel Ridley nigel at rmk.co.il
Sun Jul 15 19:47:49 BST 2007


Nigel Ridley wrote:
> Nigel Ridley wrote:
>> D. Michael McIntyre wrote:
> 
> [snip]
>> Yes you are right - I should have given more info - sorry.
>>
>> I cannot complete a boot into my Kde desktop - it freezes trying to load all the 
>> task bar etc.
>>
>> If I boot into 'recovery mode' everything is fine until it gets to:
>> 'Preparing restricted drivers'
>> then it gives the error message:
>> 'id-static: final link failed : No space left on device'
>>
>> The output of 'df -hT':
>> Filesystem  Type    Size  Used Avail Use% Mounted on
>> /dev/hda1 reiserfs  2.8G  2.2G  622M  79% /
>> varrun	   tmpfs    94M    12K  94M    1% /var/run
>> varlock	   tmpfs    94M      0  94M    0% /var/lock
>> procbususb usbfs    94M    68K  94M    1% /proc/bus/usb
>> udev       tmpfs    94M      0  94M    1% /dev
>> devshm     tmpfs    94M    68K  94M    0% /dev/shm
>> lrm  	   tmpfs    94M    33M  61M    36% /lib/modules/2.6.20-16-generic/volatile
>> /dev/hda2 reiserfs  2.4G  975M 1.4G    41% /home
>>
>> Once again, sorry for the lack of info - I was kind of tired and a bit frustrated 
>> that it happened again just when I needed to get some work done.
>>
>> Strange thing - I just successfully booted it now (letting it rest overnight) but 
>> I also, before that booted into 'recovery mode' and still got the above (from 'df 
>> -hT') but no 'id-static: final link failed : No space left on device'.
>> Strange very strange.........
>>
>> Anyways, I think I will do a clean install of Dapper Drake as I don't want future 
>> problems.
>> It would be interesting to know what the problem was and why though.
>>
>> Blessings,
>>
>> Nigel
>>
> 
> Solved! :-)
> 
> The culprit was/is a Microsoft USB mouse! One of those laptop small optical ones.
> If I connect it before booting I get the problem [of not being able to get to my 
> desktop] - if I connect it afterwards, it works fine.
> Strange thing though, I also have a Kensington optical USB mouse and it gives no 
> problems [when connected prior to booting] - go figure.
> 
> I tried lots of combinations to figure this out.
> 
> Blessings,
> 
> Nigel
> 

It looks as if it was a coincidence (the mouse thing that is). I tried to boot it 
again this afternoon and 'no-go' - in the end it was the added memory stick 
(128MB) that had failed and the onboard memory (64MB) just isn't enough to get 
things going.

Oh well have to try and find some new memory for this old bird.

Blessings,

Nigel

-- 
OliveRoot Ministries
http://www.oliveroot.net/

PrayingForIsrael.net
http://www.prayingforisrael.net/





More information about the kubuntu-users mailing list