Updates

Terence Simpson stdin at stdin.me.uk
Wed Jul 11 16:19:48 BST 2007


Neil Winchurst wrote:
> On Wed, 11 Jul 2007 15:34:41 +0100
> Terence Simpson <stdin at stdin.me.uk> wrote:
>   
>>>   
>>>       
>> I'd use konsole and see exactly why the package is marked as "broken".
>> sudo apt-get dist-upgrade
>>
>> And see why you can't remove it.
>> sudo apt-get remove python-uno
>>
>> Terence
>>     
>
> I have run check and here is the result
>
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> You might want to run ‘apt-get -f install’ to correct these.
> The following packages have unmet dependencies.
>   python-uno: Depends: openoffice.org-core (= 2.0.4-0ubuntu5) but
> 2.0.4-0ubuntu6 is installed E: Unmet dependencies. Try using -f.
>
> It seems that I have the wrong version of openoffice.org-core. However
> the version I have seems to be slightly newer than the one required. I
> did try using -f but it did not work.
>
> Neil
>
>   
OK, 1st make sure that your version of openoffice.org-core and 
python-uno are from the official repos, use "apt-cache policy <Package>" 
command to see what repo they are from.
If they are from the official repositories then you have a couple of 
options; 1) wait a while and see if it's fixed, 2) Report a bug on 
launchpad against python-uno about it's dependences.
If they aren't from the official repositories then you can either remove 
the repositories and update the package list to see if that fixes it, or 
contact the packager and report the problem.

Terence




More information about the kubuntu-users mailing list