Via Unichrome P4M800 CE-pro

FX Fraipont fxfrpt at gmail.com
Sun Feb 18 16:39:18 UTC 2007


I bought a Clevo laptop which uses a via P4M800 CE-pro graphics chip and 
a synaptics touchpad, and I cannot make it work under Kubuntu. Actually, 
I have tried half a dozen linux distributions, and the only one with 
which it is almost usable is Fedora Core 6. I say almost because that's 
with the vesa driver, and the fonts are not very good-looking.

I tried the via and the unichrome driver, which do not work at all: no 
X, often with the machine freezing completely.

With vesa, kde loads, I can enter my password but when I move the cursor 
everything freezes and I have to reboot. My xorg.conf files detects a 
keyboard and a mouse and a Wacom tablet. I thought that was the problem, 
but removing everything related to wacom does not make the slightest 
difference.

I googled and read everything relating to synaptics touchpads under 
Ubuntu, manually inserted all the relevant devices and options in 
xorg.conf, to no avail.

I tried downloading the Openchrome driver from cvs and compiled it, but 
it won't work, which seems logical since my version of the chipset is 
not supported yet.

I then tried downloading and compiling the kernel display driver code 
from viaarena, which involves compiling the driver then mesa, but I get 
stuck at the step that says

    cp -a [Via Driver Package Name]/src/3D/DRI_FC6  src/mesa/drivers/dri/via
    cd src/mesa/drivers/dri/via
    make

compiling fails because there's no makefile

the DRI_FC6 is also surprising, since there's a DRI_Ubuntu, but it is empty.

This is even though the via driver and mesa compile just right. But I 
can't get a via_drv.ko , whatever I try.

I've been trying this for two weeks now, and I feel very frustrated, to 
say the least...

Can anyone offer a suggestion that I haven't tried yet? thanks a lot.

fx




More information about the kubuntu-users mailing list