Notebook touchpad Kubuntu freeze

D. Michael McIntyre michael.mcintyre at rosegardenmusic.com
Sat Feb 3 18:56:52 UTC 2007


On Saturday 03 February 2007 8:19 am, FX Fraipont wrote:
> I have tried your suggestion before, but when I launch the kde with
> startx and it freezes, ctrl-alt-delete won't work and I have to reboot
> using the power button, so I never get any hints.

The first thing I wonder is whether this is really a freeze.  How much 
experience do you have with Linux behaving badly?  Would you know the 
difference between a total hard freeze and the appearance of a freeze due to 
an X11 problem or a disk thrashing problem that renders the system almost but 
not quite really frozen?

If you don't know already, some of these things like Ctrl+Alt+F1 to go to 
another virtual console might actually take up to several minutes to work, if 
for example, some catastrophic memory leak is burning your CPU cycles and 
system busses at the max shuffling data to your swap partition.

In addition, I would suggest that since you are having this problem even with 
startx, it's time to start trying to do this one small piece at a time.  A 
KDE system is built out of lots of little pieces, and you can start them one 
at a time to narrow down your problem.

To get basic no frills X11 running, begin by running

	xinit

You should get a hideous moiré pattern background with an X cursor, and an 
xterm session at the top left of the screen.  Wave the mouse around, and see 
if it freezes. Try clicking, and see if it freezes.  (If it does, try 
Ctrl+Alt+Backspace to kill the X session, and wait at least three minutes 
before hitting the power button.)

If that worked, mouse over to the xterm session and give it the focus so you 
can type commands there.  I usually bring things up in this order:

	kwin &
	kdesktop &
	kicker &

I'd try mousing around between each stage to see if that component has any 
effect on the problem.

If all of this is up, you basically have a working bare bones KDE session.  
Does it work?

If you ran into a freeze at any stage of the way, and especially at the bare 
bones xinit stage, then I'd start thinking about tinkering with the hardware 
config directly.  You don't say what suggestions you followed in playing with 
xorg.conf.  I'd start by disabling the touchpad, enabling only the mouse, and 
if that didn't work, I'd switch them around and use only the touchpad.  If 
that didn't work, and the mouse was definitely the issue, I guess I'd suspect 
it was some issue with the vesa driver.

My laptop has a VIA chipset whose video only runs in VESA mode too, and lspci 
shows a lot of "unknown chipset" or something to that effect.  I eventually 
gave up trying to run Linux on that, but not because of anything so dire as 
what you're facing.

Anyway, just thoughts off the top of my head.  I think I'm going to go out in 
the bitter cold and try to take pictures of frozen creeks.
-- 
D. Michael McIntyre 




More information about the kubuntu-users mailing list