Problems Upgrading to Edgy

D. Michael McIntyre michael.mcintyre at rosegardenmusic.com
Thu Feb 1 13:52:01 UTC 2007


On Wednesday 31 January 2007 7:17 pm, Robert Tilley wrote:
> dpkg: error
> processing
> /var/cache/apt/archives/libarts1-audiofile_4%3a3.5.6-0ubuntu1~edgy1_i386.de
>b (--unpack):
>  trying to overwrite `/usr/lib/libarts_audiofile.so', which is also in
> package kdemultimedia-dev

> I've tried deleting the file `/usr/lib/libarts_audiofile.so' (so it _can't_
> be overwritten) to solve this problem.  Does anyone have any further ideas?

I used to wrestle with this kind of nonsense on Debian Sid pretty regularly.  
In fact, this exact scenario seems familiar somehow.

I always dealt with this kind of thing through some random, seat of the pants 
process.  I don't have any clear direction to give you.  I wish I did, but 
I'm drawing a blank.  

I guess I'd try 

	sudo apt-get update
	sudo apt-get dist-upgrade

just in case there are new fixed packages.  (Unlikely in this case.)

Then I'd try

	sudo dpkg -i kdemultimedia-dev
	sudo apt-get dist-upgrade

and see if that worked.  If not, I don't know my next move.  Format/reinstall 
possibly, depending on my patience level.  I suppose the right thing to do is 
figure out how Ubuntu bug reports work and go tell somebody about this.  It 
looks like a pretty clear case of broken packages to me.

Will Ubuntu even try to fix issues like this?  I have no clue.  I haven't 
tasted this flavor of trouble on Ubuntu yet, because I'm sticking with 
Dapper, probably until the next LTS, and if the LTS to LTS upgrade doesn't 
work, I'm going to scream, give up on Linux, and start reading books or 
something.

-- 
D. Michael McIntyre 




More information about the kubuntu-users mailing list