Guarddog

O. Sinclair o.sinclair at gmail.com
Wed Aug 29 12:59:24 UTC 2007


Casper Skovby wrote:
> Casper Skovby wrote:
> 
>>> On Wednesday 29 August 2007 01:15:15 Casper Skovby wrote:
>>>
>>   
>>>>>>> Hi,
>>>>>>>
>>>>>>> I'm running kubuntu feisty and I've just installed the firewall
>>>>>>> Guarddog. I've got problems sending emails with thunderbird. There's no
>>>>>>> problems receiving emails. I've tried to check all protocols but it's
>>>>>>> not possible to send any emails anyway. Has anybody experienced the same
>>>>>>> problem and solved it?
>>>>>>>
>>>>       
> have you looked at these instructions and followed them for mail?
> http://www.simonzone.com/software/guarddog/manual2/using-guarddog.html#id2406324
> you must of course allow smtp and if you are using gmail make sure you 
> allow SSL and/or TLS. I have a feeling your problem lies in the fact 
> that you have not allowed these protocols under "Mail".
> 
> Sinclair
> 
> Yes I have followed these instructions. I have tried to allow all protocols but it does not help. Any other suggestions?
> 
Now you had me curious - as a matter of fact I have been using a local
smtp server myself. The problem is quite simply that Guarddog has not
defined the TLS "protocol" under Mail. This means trying to use the
smtp.gmail.com with TLS and port 587 does not work as Guarddog does not
allow anything unless you tell it to.

Do like this:
1. Open Guarddog
2. Go to Advanced tab
3. Define a "User defined protocol", call it TLS (dont press return just
yet..)
4. Set it to TCP port 587 (dont press return just yet...)
5. Press "Apply"
6. Go to tab "Protocol", choose Zone "Internet"
7. You should now have a protocol TLS below "User Defined"
8. Allow this protocol and press "Apply"
if all goes well you can now send using gmail smtp settings - I can at
least.

Incidently I tried KmyFirewall and found that Thunderbird slowed down
for no apparent reason. Really strange.

good luck
Sinclair





More information about the kubuntu-users mailing list