install gparted leads to "Permission denied" errors, halting boot. - Solved

Anton Rolls anton at
Thu Aug 16 07:18:49 UTC 2007

I solved it.

An extra entry was added to /etc/fstab (probably by gparted),
which specified sda4 mounted on /.
That would have overridden the mount point with the OS on it!
(I think).
So I think kubuntu was able to boot until /etc/fstab
was processed, at which stage the bootable filesystem
became inaccessible.

I was able to boot into Kubuntu using the live install cd,
mount the os filesystem, chroot into it, then edit the
/etc/fstab file, commenting the last entry.



> -----Original Message-----
> From: kubuntu-users-bounces at
> [mailto:kubuntu-users-bounces at]On Behalf Of Anton Rolls
> Sent: Thursday, 16 August 2007 1:54 pm
> To: Kubuntu Users
> Subject: install gparted leads to "Permission denied" errors, halting
> boot.
> On Kubuntu 7.04,
> I went to the konsole and tried to run gparted.
> It replied "gparted isn't installed, try apt-get install gparted".
> I did that, and gparted was installed and could be used.
> (gparted was used to add an extended partition with two logical
> partitions.)
> Next reboot and Kubuntu can't boot all the way, displaying lots
> of "/etc/init.d/rc: 2: sed: Permission denied" errors.
> (I ran a system rescue cd and used gparted to remove the extra
> extended partition. Still can't boot.)
> What could have happened ?
> Regards,
> Anton.

More information about the kubuntu-users mailing list