Kaffeine - stopped working?

Ian Rose ian at themagictree.co.uk
Sun Apr 1 14:53:15 BST 2007


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Aidan wrote:
> The media player that I use for watching television stopped working for me
> last night (possibly after some updates). When I click on the icon, the
> launch icon bounces up and down for several seconds, then disappears
without
> the application being launched. I tried to reinstall kaffeine today, but I
> got an error message that it failed to download. Anyone have any
suggestions?
>
I may be able to help:

This can be caused when you shut down KDE and Kaffeine is still
running. When you log back in, KDE attempts to restore Kaffeine, but
it can't (I don't know why). However an "orphan" kaffeine process
hangs around, so that when you attempt to  launch kaffeine manually,
it thinks it is already running.

To find the process, do

ps aux | grep kaffeine

the rogue process should be easy to spot - the id for the process will
be the first (usually 4-digit) number. Just
kill (number)
and you should be able to start kaffeine normally. You can prevent
this from happening again by going to "System Settings" > "Advanced" >
"Session Manager" >  and then either starting with a blank session or
adding "kaffeine" to the applications to be excluded from sessions.

Hope that helps

Ian




-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGD7lKGqrW91lKBAcRArxzAJ4rLiig8uA63JSwCcUBOyv7Ze/EsQCgxoAs
weCDY//DmojtgdvV4iYc+QE=
=4Cdy
-----END PGP SIGNATURE-----




More information about the kubuntu-users mailing list