How to get rid of faulty packages

Ignazio Palmisano ignazio_io at
Wed Oct 4 17:42:25 UTC 2006

Hi list,
I just managed to harm my system by trying to install gforge on it; what
happened is that, after installing many needed packages, including
postgresql version 7.4, synaptic told me that there were some errors and
some packages were left not configured. Then, since I noticed there were
more uptodate repositories for gforge, I added them to the sources.list
file and tried to uninstall the old version and replace it with the new
one. Problem is, the package gforge-db-postgresql says there is an error
during the removal process (it cannot find a /var/lib/postgresql/
file). Then, I decided to remove everything and restart the whole
process... and I ended up with a postgresql-8.1 package expressing the
same behavior, this time with a:

/var/lib/dpkg/info/postgresql-8.1.prerm: line 17:
/usr/share/postgresql-common/maintscripts-functions: Nessun file o
directory (no file or directory)

so now I have two packages that are listed as broken, I cannot uninstall
them, and reinstalling has no effect apart from bringing up a lot of
stuff that then I cannot remove completely. I already tried with KOrphan
and with dpkg --force-all --purge, with no joy. Any other hint on how to
remove obstinated packages? I'm thinking about looking into the list of
installed files and hunt them one at a time, but that seems time
consuming and inaccurate at best...

Thank you for your help,
Ignazio Palmisano
Ph.D. Student - palmisano at, ignazio_io at

More information about the kubuntu-users mailing list