No Pairing BT Headset Ericson HBH-610a

Siggi hofstett at sh-sw.de
Mon Oct 2 15:45:20 BST 2006


Hello Group,

I tried several descriptions on the Ubuntu Forums with no success. For any 
reason i'm not able to pair my headset with my laptop.

I want to use my Ericson HBH-610a Headset in my Kubuntu Edgy Installation.

Fllowing software i have installed:
aptitude  search bluez
bluez-btsco
bluez-cups
bluez-hcidump
bluez-pcmcia-support 
bluez-pin 
bluez-utils                                                                     - 

This is my little script with i try to pair my laptop with my BT Headset:
#!/bin/bash

hciconfig hci0 revision:
<output>
hci0:   Type: USB
        BD Address: 00:16:41:5C:39:BE ACL MTU: 384:8 SCO MTU: 64:8
        Build 2422
        Chip version: BlueCore4-External
        Max key size: 56 bit
        SCO mapping:  HCI
<output>

hciconfig hci0 voice 0x0060

hcitool scan
<output>
	00:12:EE:AB:EB:6C       HBH-610a
<output>
btsco -v 00:12:EE:AB:EB:6C
<output>
btsco v0.4c
Device is 1:0
Voice setting: 0x0060
Can't connect RFCOMM channel: Connection refused
<output>

I had also a hcidump running during the script, which shows me:
<snip>
> ACL data: handle 46 flags 0x02 dlen 16
    L2CAP(s): Connect rsp: dcid 0x0054 scid 0x0041 result 1 status 1
      Connection pending - Authentication pending
> HCI Event: PIN Code Request (0x16) plen 6
< HCI Command: PIN Code Request Negative Reply (0x01|0x000e) plen 6
> HCI Event: Command Complete (0x0e) plen 10
> ACL data: handle 46 flags 0x02 dlen 16
    L2CAP(s): Connect rsp: dcid 0x0054 scid 0x0041 result 3 status 0
      Connection refused - security block
<snip>

Here my configs 
hcid.conf 

# HCId options
options {
        autoinit yes;
        security auto;
        pairing multi;
       pin_helper /usr/lib/kdebluetooth/kbluepin
}

# Default settings for HCI devices
device {
        name "%h-%d";
        class 0x100;
        iscan enable; pscan enable;
        lm accept;
        lp rswitch,hold,sniff,park;
}

rfcomm.conf
rfcomm0 {
        bind yes;
        device "BT-MAC"
        channel 1;
        comment "HBH-610a";
}

Any help is very appreciated ! ;o)

Thanks in advance.

-- 
MfG Siggi



More information about the kubuntu-users mailing list