Solved Re: remapping mouse buttons

Nigel Ridley nigel at
Fri Nov 24 19:18:56 UTC 2006

Nigel Ridley wrote:
> Fred Schaer wrote:
>> Hi,
>> I had the same kind of problem with my M$ 
>> intelli-internet-wireless-explorer-stupid-name mouse : buttons on the 
>> thumb were not activated correctly...
>> To have those 2 buttons OK, I had to change the mouse section in my 
>> xorg.conf file. Key options were :
>> Option      "ButtonMapping" "1 2 3 6 7"
>> Option      "ZAxisMapping" "4 5"
>> Option      "Emulate3Buttons" "false"
>> Maybe you'd like to play with these options ?
>> Cheers
> No joy :-( The two upper thumb buttons, when clicked, move a 'wide' web 
> page left and right as if you were to drag the bottom scroll bar.
> I shall keep looking ..........
> What is the name of the app that shows mouse button numbers when you 
> click them?
> Blessings,
> Nigel
>> Nigel Ridley a écrit :
>>> Since doing a fresh install of Edgy my logitech optical trackman 8 
>>> button mouse behaves differently :-(
>>> It used to be that of the three buttons that are next to my thumb, the 
>>> top two would act the same as clicking with the scroll wheel - opening a 
>>> new tab in Konqueror etc. BUT more importantly, it would paste 
>>> highlighted text. Now only clicking the scroll wheel does this.
>>> I know that that is probably how it should be but it was so much easier 
>>> just having to move my thumb up a tiny fraction to paste stuff. Now I 
>>> have to highlight using the trackball and click the very small scroll 
>>> wheel which is next to the trackball which, because of their close 
>>> proximity causes the mouse pointer to move before I can click in the 
>>> right place ughh!
>>> Anyway. How can I remap the mouse buttons to revert back to using button 
>>> number 6 or 7 (I'm not sure which but it is one of those two) as a 
>>> 'middle' mouse button - so that I can paste with it?
>>> Blessings,
>>> Nigel

I found the answer on the ubuntu forums. I have pasted the relevant message:

I asked about ButtonMapping on the xorg mailing list (btw, I think it's 
intended for developers only...there doesn't appear to be a user my newbie-ness barged right in the middle of their developer 
discussions :blush: ). Anyway, one person replied:
"xev and other X applications see the logical buttons. They expect 1 to 
be select, 2 to be paste, 3 to be context menu, 4 scroll up, 5 down, 6 
left, 7 right."
So, I think I get some of it finally. ButtonMapping maps physical 
buttons on the mouse to logical buttons. The places from left to right 
are the physical buttons and the numbers in those places are the logical 
buttons. To be more clear, to get standard right-handed mouse 
configuration we use:

"ButtonMapping" "1 2 3 6 7"

This makes button '1'(the button under your index finger if you're 
right-handed) map to the 'select' action and button '3'(the button under 
your middle finger) map to the 'context menu' action. So, this means to 
get left-handed mouse configuration we simply switch:

"ButtonMapping" "3 2 1 6 7"

I just tested it and this is exactly what happens. I was also told that 
the PS/2 driver we're using only has fields for 5 physical buttons, so 
any numbers after "1 2 3 6 7 ..." wouldn't mean anything (may cause 
problems even, haven't tried). This is also why xev never sees any 
action from my tilt-wheel. If I wanted to be crazy (and usually I do, 
just not in this case) I could map the wheel to forward/back with

"ButtonMapping" "1 2 3 4 5"

BTW Use 'exev' to find out button mapping numbers

I changed my xorg file to read:

"ButtonMapping" "1 6 3 2 7"

and now the top rear thumb button now pastes!:-) - I'm so happy I could 
sing - but you probably don't want to hear my 'joyful noise'.





More information about the kubuntu-users mailing list